summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-07-13 21:32:18 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-07-13 21:32:18 +0000
commit784852ab723016f80739ae796ab2edcb27fcf799 (patch)
treeaffbd2a16876579f596e65af80414ded6abf41da /pkgs/os-specific
parentf85cf594d393c38c0a7d6f10fa54556b541fc7c4 (diff)
downloadnixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar.gz
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar.bz2
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar.lz
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar.xz
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.tar.zst
nixlib-784852ab723016f80739ae796ab2edcb27fcf799.zip
Making the two ralink wireless firmwares have files that don't collide on buildEnv.
svn path=/nixpkgs/trunk/; revision=22590
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/rt2870/default.nix4
-rw-r--r--pkgs/os-specific/linux/firmware/rt73/default.nix4
2 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/os-specific/linux/firmware/rt2870/default.nix b/pkgs/os-specific/linux/firmware/rt2870/default.nix
index 6d28ba2ba858..388d3a503436 100644
--- a/pkgs/os-specific/linux/firmware/rt2870/default.nix
+++ b/pkgs/os-specific/linux/firmware/rt2870/default.nix
@@ -1,6 +1,6 @@
 {stdenv, fetchurl, unzip}:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "rt2870-fw-22";
   src = fetchurl {
     url = "http://www.ralinktech.com/download.php?t=U0wyRnpjMlYwY3k4eU1ERXdMekF6THpNeEwyUnZkMjVzYjJGa01UWXpPRGs1T0Rnek5pNTZhWEE5UFQxU1ZESTROekJmUm1seWJYZGhjbVZmVmpJeUM%3D";
@@ -16,7 +16,7 @@ stdenv.mkDerivation {
   # says: "Your rights to redistribute the Software shall be
   # contingent upon your installation of this Agreement in its
   # entirety in the same directory as the Software."
-  installPhase = "ensureDir $out; cp * $out";
+  installPhase = "ensureDir $out/${name}; cp *.bin $out; cp *.txt $out/${name}";
   
   meta = {
     description = "Firmware for the Ralink RT2870 wireless cards";
diff --git a/pkgs/os-specific/linux/firmware/rt73/default.nix b/pkgs/os-specific/linux/firmware/rt73/default.nix
index ea266ea0591e..32c097a62df9 100644
--- a/pkgs/os-specific/linux/firmware/rt73/default.nix
+++ b/pkgs/os-specific/linux/firmware/rt73/default.nix
@@ -1,6 +1,6 @@
 {stdenv, fetchurl, unzip}:
 
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
   name = "rt73-fw-1.8";
   src = fetchurl {
     url = "http://www.ralinktech.com/download.php?t=U0wyRnpjMlYwY3k4eU1EQTVMekF6THpNeEwyUnZkMjVzYjJGa056YzVPVE13TmpZMk9TNTZhWEE5UFQxU1ZEY3hWMTlHYVhKdGQyRnlaVjlXTVM0NEM%3D";
@@ -16,7 +16,7 @@ stdenv.mkDerivation {
   # says: "Your rights to redistribute the Software shall be
   # contingent upon your installation of this Agreement in its
   # entirety in the same directory as the Software."
-  installPhase = "ensureDir $out; cp * $out";
+  installPhase = "ensureDir $out/${name}; cp *.bin $out; cp *.txt $out/${name}";
   
   meta = {
     description = "Firmware for the Ralink RT73 wireless card";