summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorRyan Trinkle <ryan.trinkle@gmail.com>2017-07-05 15:54:45 -0400
committerRyan Trinkle <ryan.trinkle@gmail.com>2017-07-05 16:04:39 -0400
commit754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2 (patch)
treeece30c8c73d51da59971d3bad8fee4b595b80b0b /pkgs/os-specific
parentaad0ebb19454227bcca81f4856c9f5f2fe55fa2b (diff)
downloadnixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar.gz
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar.bz2
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar.lz
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar.xz
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.tar.zst
nixlib-754c3f6ba4a33cfd4f573c1fee3b5df74ba00ee2.zip
cc-wrapper: fix response file parsing on ios-cross
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/ios-cross/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/os-specific/darwin/ios-cross/default.nix b/pkgs/os-specific/darwin/ios-cross/default.nix
index e0981d48c8c9..f56c8148317d 100644
--- a/pkgs/os-specific/darwin/ios-cross/default.nix
+++ b/pkgs/os-specific/darwin/ios-cross/default.nix
@@ -6,7 +6,9 @@
 , stdenv
 , coreutils
 , gnugrep
-, hostPlatform, targetPlatform
+, buildPackages
+, hostPlatform
+, targetPlatform
 }:
 
 /* As of this writing, known-good prefix/arch/simulator triples:
@@ -29,7 +31,7 @@ let
   sdk = "/Applications/Xcode.app/Contents/Developer/Platforms/iPhone${sdkType}.platform/Developer/SDKs/iPhone${sdkType}${sdkVer}.sdk";
 
 in (import ../../../build-support/cc-wrapper {
-    inherit stdenv coreutils gnugrep runCommand;
+    inherit stdenv coreutils gnugrep runCommand buildPackages;
     nativeTools = false;
     nativeLibc = false;
     inherit binutils;