summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-11-09 11:55:23 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-11-09 11:55:23 +0000
commit6d092c3371841562f881b9ff91c2ce3a79f1ef7c (patch)
tree91a5157167415ca90e75e9de560b31c7c1b687e1 /pkgs/os-specific
parentf2f5176551bc72680d19396ea32de56a1e251c92 (diff)
downloadnixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar.gz
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar.bz2
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar.lz
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar.xz
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.tar.zst
nixlib-6d092c3371841562f881b9ff91c2ce3a79f1ef7c.zip
Adding kvm88, although without the patches kvm86 had for some nix advantages (samba, ...),
because they don't apply directly.

svn path=/nixpkgs/trunk/; revision=18309
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kvm/88.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/kvm/88.nix b/pkgs/os-specific/linux/kvm/88.nix
new file mode 100644
index 000000000000..bfbfbd8e47c1
--- /dev/null
+++ b/pkgs/os-specific/linux/kvm/88.nix
@@ -0,0 +1,34 @@
+{stdenv, fetchurl, kernelHeaders, zlib, SDL, alsaLib, pkgconfig, pciutils}:
+   
+assert stdenv.isLinux;
+   
+stdenv.mkDerivation rec {
+  name = "kvm-88";
+   
+  src = fetchurl {
+    url = "mirror://sourceforge/kvm/${name}.tar.gz";
+    sha256 = "0gmmcwgkfk15wkcjaaa28nrzb0w3vbhg8p585qin61hz6kcy8ryw";
+  };
+
+  configureFlags = "--enable-io-thread";
+
+  # e2fsprogs is needed for libuuid.
+  # rsync is a weird dependency used for copying kernel header files.
+  buildInputs = [zlib SDL alsaLib pkgconfig pciutils];
+
+  preConfigure = ''
+    for i in configure kvm/configure kvm/user/configure; do
+      substituteInPlace $i --replace /bin/bash $shell
+    done
+    
+    substituteInPlace kvm/libkvm/Makefile --replace kvm_para.h kvm.h # !!! quick hack
+
+    # This prevents the kernel module from being built.
+    rm kvm/kernel/configure
+  '';
+
+  meta = {
+    homepage = http://kvm.qumranet.com/;
+    description = "A full virtualization solution for Linux on x86 hardware containing virtualization extensions";
+  };
+}