summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-22 15:57:51 -0500
committerGitHub <noreply@github.com>2018-04-22 15:57:51 -0500
commit6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc (patch)
tree377081d5fe95ae885697505f9c0ea87351af1948 /pkgs/os-specific
parent6a819c8f8c9100eb1a79515f10ad2d0d49b42ed5 (diff)
downloadnixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar.gz
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar.bz2
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar.lz
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar.xz
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.tar.zst
nixlib-6a4cc3562cf6e41272e542f3aeb7ae46cec45ecc.zip
Revert "initial TBS driver"
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/tbs/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/pkgs/os-specific/linux/tbs/default.nix b/pkgs/os-specific/linux/tbs/default.nix
deleted file mode 100644
index e4b954d4dbf5..000000000000
--- a/pkgs/os-specific/linux/tbs/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ stdenv, fetchFromGitHub, kernel, kmod, perl, patchutils, perlPackages }:
-let
-  media = fetchFromGitHub {
-    owner = "tbsdtv";
-    repo = "linux_media";
-    rev = "14ebbec91f2cd0423aaf859fc6e6d5d986397cd4";
-    sha256 = "1cmqj3kby8sxfcpvslbxywr95529vjxzbn800fdp35lka1fv962h";
-  };
-  build = fetchFromGitHub {
-    owner = "tbsdtv";
-    repo = "media_build";
-    rev = "c340e29a4047e43f7ea7ebf19e1e28c1f2112d05";
-    sha256 = "0hfn1j9qk8lh30z3ywj22qky480nsf8z2iag2bqhrhy4375vjlbl";
-  };
-in stdenv.mkDerivation {
-  name = "tbs-2017-11-05-${kernel.version}";
-
-  srcs = [ media build ];
-  sourceRoot = "${build.name}";
-
-  preConfigure = ''
-    make dir DIR=../${media.name}
-  '';
-
-  postPatch = ''
-    patchShebangs .
-
-    sed -i v4l/Makefile \
-      -i v4l/scripts/make_makefile.pl \
-      -e 's,/sbin/depmod,${kmod}/bin/depmod,g' \
-      -e 's,/sbin/lsmod,${kmod}/bin/lsmod,g'
-
-    sed -i v4l/Makefile \
-      -e 's,^OUTDIR ?= /lib/modules,OUTDIR ?= ${kernel.dev}/lib/modules,' \
-      -e 's,^SRCDIR ?= /lib/modules,SRCDIR ?= ${kernel.dev}/lib/modules,'
-  '';
-
-  buildFlags = [ "VER=${kernel.modDirVersion}" ];
-  installFlags = [ "DESTDIR=$(out)" ];
-
-  hardeningDisable = [ "pic" "format" ];
-  nativeBuildInputs = [ patchutils kmod perl perlPackages.ProcProcessTable ];
-
-  meta = with stdenv.lib; {
-    homepage = https://www.tbsdtv.com/;
-    license = licenses.gpl2;
-    maintainers = with maintainers; [ ck3d ];
-    priority = 20;
-  };
-}