summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-26 15:26:33 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-26 15:26:33 +0100
commit68bcfb32699b32f802c797f8629b4d507cd1b10a (patch)
tree84a85a14c4ffc464bc46a0949ecdb9e65d9e3f0b /pkgs/os-specific
parentb03ac7d22b65f4719c8efbdf3400b5c2a927aa79 (diff)
parent63e3eae02f7342c8fc62bc458dae3bea95815f7d (diff)
downloadnixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar.gz
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar.bz2
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar.lz
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar.xz
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.tar.zst
nixlib-68bcfb32699b32f802c797f8629b4d507cd1b10a.zip
Merge #33049: linux: 4.14.8 -> 4.14.9
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/linux-4.14.nix4
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix4
2 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/os-specific/linux/kernel/linux-4.14.nix b/pkgs/os-specific/linux/kernel/linux-4.14.nix
index ffb0974e0522..c854f880ab94 100644
--- a/pkgs/os-specific/linux/kernel/linux-4.14.nix
+++ b/pkgs/os-specific/linux/kernel/linux-4.14.nix
@@ -3,7 +3,7 @@
 with stdenv.lib;
 
 import ./generic.nix (args // rec {
-  version = "4.14.8";
+  version = "4.14.9";
 
   # modDirVersion needs to be x.y.z, will automatically add .0 if needed
   modDirVersion = concatStrings (intersperse "." (take 3 (splitString "." "${version}.0")));
@@ -13,6 +13,6 @@ import ./generic.nix (args // rec {
 
   src = fetchurl {
     url = "mirror://kernel/linux/kernel/v4.x/linux-${version}.tar.xz";
-    sha256 = "0cwk9liv79hw5l34xvwnf05spx1jvv8q8w9lfbw4lw8xldxwbg3f";
+    sha256 = "1vqllh36wss4dsdvb12zchy6hjaniyxcla5cg8962xrkim2bpk6g";
   };
 } // (args.argsOverride or {}))
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index 9124559ef7a0..355fbde62680 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -234,7 +234,7 @@ let
     };
 in
 
-assert stdenv.lib.versionAtLeast version "4.15" -> libelf != null;
+assert stdenv.lib.versionAtLeast version "4.14" -> libelf != null;
 assert stdenv.lib.versionAtLeast version "4.15" -> utillinux != null;
 stdenv.mkDerivation ((drvAttrs config stdenv.platform (kernelPatches ++ nativeKernelPatches) configfile) // {
   name = "linux-${version}";
@@ -243,7 +243,7 @@ stdenv.mkDerivation ((drvAttrs config stdenv.platform (kernelPatches ++ nativeKe
 
   nativeBuildInputs = [ perl bc nettools openssl gmp libmpc mpfr ]
       ++ optional (stdenv.platform.kernelTarget == "uImage") ubootTools
-      ++ optional (stdenv.lib.versionAtLeast version "4.15") libelf
+      ++ optional (stdenv.lib.versionAtLeast version "4.14") libelf
       ++ optional (stdenv.lib.versionAtLeast version "4.15") utillinux
       ;