summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-03-28 00:43:38 +0000
committerGitHub <noreply@github.com>2018-03-28 00:43:38 +0000
commit5e4c376490b2c38ef0d81f3d956eb568fbf443f7 (patch)
treec8bc1370101496debbdc07c872631e6bb7462020 /pkgs/os-specific
parent15c744a06d606ac5f9f53498756765a4764ce6ca (diff)
parentecf5caf457331ca777f498a94dea34e9befac028 (diff)
downloadnixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar.gz
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar.bz2
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar.lz
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar.xz
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.tar.zst
nixlib-5e4c376490b2c38ef0d81f3d956eb568fbf443f7.zip
Merge pull request #37930 from dtzWill/update/firmware-linux-nonfree-03-20-2018
firmwareLinuxNonfree: 2018-01-04 -> 2018-03-20
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/firmware-linux-nonfree/default.nix49
1 files changed, 5 insertions, 44 deletions
diff --git a/pkgs/os-specific/linux/firmware/firmware-linux-nonfree/default.nix b/pkgs/os-specific/linux/firmware/firmware-linux-nonfree/default.nix
index acdba5987bbf..206787ecb8b7 100644
--- a/pkgs/os-specific/linux/firmware/firmware-linux-nonfree/default.nix
+++ b/pkgs/os-specific/linux/firmware/firmware-linux-nonfree/default.nix
@@ -2,51 +2,12 @@
 
 stdenv.mkDerivation rec {
   name = "firmware-linux-nonfree-${version}";
-  version = "2018-01-04-${src.iwlRev}";
+  version = "2018-03-20";
 
-  # The src runCommand automates the process of building a merged repository of both
-  #
-  # https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/
-  # https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/
-  #
-  # This gives us up to date iwlwifi firmware as well as
-  # the usual set of firmware. firmware/linux-firmware usually lags kernel releases
-  # so iwlwifi cards will fail to load on newly released kernels.
-  #
-  # To update, go to the above repositories and look for latest tags / commits, then
-  # update version to the more recent commit date
-
-  src = runCommand "firmware-linux-nonfree-src-merged-${version}" {
-    shallowSince = "2017-10-01";
-    baseRev = "65b1c68c63f974d72610db38dfae49861117cae2";
-    iwlRev = "iwlwifi-fw-2017-11-15";
-
-    # When updating this, you need to let it run with a wrong hash, in order to find out the desired hash
-    # randomly mutate the hash to break out of fixed hash, when updating
-    outputHash = "1anr7fblxfcrfrrgq98kzy64yrwygc2wdgi47skdmjxhi3wbrvxz";
-
-    outputHashAlgo = "sha256";
-    outputHashMode = "recursive";
-
-    # Doing the download on a remote machine just duplicates network
-    # traffic, so don't do that.
-    preferLocalBuild = true;
-
-    nativeBuildInputs = [ cacert git gnupg ];
-  } ''
-    git init src && (
-      cd src
-      git config user.email "build-daemon@nixos.org"
-      git config user.name "Nixos Build Daemon $name"
-      git remote add base https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
-      git remote add iwl https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
-      git fetch --shallow-since=$shallowSince base
-      git fetch --shallow-since=$shallowSince iwl
-      git checkout -b work $baseRev
-      git merge $iwlRev)
-    rm -rf src/.git
-    cp -a src $out
-  '';
+  src = fetchgit {
+    url = "https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git";
+    sha256 = "1gh5a2km33jj151j3q7mgkjzzhaaxlqxbb53n4ff46q658gv0wma";
+  };
 
   preInstall = ''
     mkdir -p $out