summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-29 13:06:14 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-09-29 13:06:14 +0200
commit518340624d92c7d802b23e73b078010a505b3609 (patch)
tree71f3295b1faba281e56625998540b0e697cacf90 /pkgs/os-specific
parent0c0c59c7cc3a1063acd60b83b66e6011ee2677bd (diff)
parent5df3ec85d8e9afd780fa80b9f96e496a61f699c1 (diff)
downloadnixlib-518340624d92c7d802b23e73b078010a505b3609.tar
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.gz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.bz2
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.lz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.xz
nixlib-518340624d92c7d802b23e73b078010a505b3609.tar.zst
nixlib-518340624d92c7d802b23e73b078010a505b3609.zip
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/patches.nix9
-rw-r--r--pkgs/os-specific/linux/pam_usb/default.nix28
-rw-r--r--pkgs/os-specific/linux/rtl8812au/default.nix12
3 files changed, 42 insertions, 7 deletions
diff --git a/pkgs/os-specific/linux/kernel/patches.nix b/pkgs/os-specific/linux/kernel/patches.nix
index b15d66278d91..d4e9f1e72750 100644
--- a/pkgs/os-specific/linux/kernel/patches.nix
+++ b/pkgs/os-specific/linux/kernel/patches.nix
@@ -139,4 +139,13 @@ rec {
     };
 
   cpu-cgroup-v2 = import ./cpu-cgroup-v2-patches;
+
+  lguest_entry-linkage =
+    { name = "lguest-asmlinkage.patch";
+      patch = fetchpatch {
+        url = "https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git"
+            + "/patch/drivers/lguest/x86/core.c?id=cdd77e87eae52";
+        sha256 = "04xlx6al10cw039av6jkby7gx64zayj8m1k9iza40sw0fydcfqhc";
+    };
+  };
 }
diff --git a/pkgs/os-specific/linux/pam_usb/default.nix b/pkgs/os-specific/linux/pam_usb/default.nix
index a96e951bf9b1..cedb9bca1a0f 100644
--- a/pkgs/os-specific/linux/pam_usb/default.nix
+++ b/pkgs/os-specific/linux/pam_usb/default.nix
@@ -1,6 +1,32 @@
-{stdenv, fetchurl, makeWrapper, useSetUID, dbus, libxml2, pam, pkgconfig, pmount, pythonPackages}:
+{ stdenv, fetchurl, makeWrapper, useSetUID, dbus, libxml2, pam, pkgconfig, pmount, pythonPackages, writeScript }:
 
 let
+
+  # Search in the environment if the same program exists with a set uid or
+  # set gid bit.  If it exists, run the first program found, otherwise run
+  # the default binary.
+  useSetUID = drv: path:
+    let
+      name = baseNameOf path;
+      bin = "${drv}${path}";
+    in assert name != "";
+      writeScript "setUID-${name}" ''
+        #!${stdenv.shell}
+        inode=$(stat -Lc %i ${bin})
+        for file in $(type -ap ${name}); do
+          case $(stat -Lc %a $file) in
+            ([2-7][0-7][0-7][0-7])
+              if test -r "$file".real; then
+                orig=$(cat "$file".real)
+                if test $inode = $(stat -Lc %i "$orig"); then
+                  exec "$file" "$@"
+                fi
+              fi;;
+          esac
+        done
+        exec ${bin} "$@"
+      '';
+
   pmountBin = useSetUID pmount "/bin/pmount";
   pumountBin = useSetUID pmount "/bin/pumount";
   inherit (pythonPackages) python dbus-python;
diff --git a/pkgs/os-specific/linux/rtl8812au/default.nix b/pkgs/os-specific/linux/rtl8812au/default.nix
index c38fa8843f42..56f14b30acd1 100644
--- a/pkgs/os-specific/linux/rtl8812au/default.nix
+++ b/pkgs/os-specific/linux/rtl8812au/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "rtl8812au-${kernel.version}-${version}";
-  version = "4.2.2-1";
+  version = "4.3.20";
 
   src = fetchFromGitHub {
-    owner = "csssuf";
-    repo = "rtl8812au";
-    rev = "874906aec694c800bfc29b146737b88dae767832";
-    sha256 = "14ifhplawipfd6971mxw76dv3ygwc0n8sbz2l3f0vvkin6x88bsj";
+    owner = "Grawp";
+    repo = "rtl8812au_rtl8821au";
+    rev = "9c5b2978ab079081dd1e981353be681a1cf495de";
+    sha256 = "0bx1vgs2qldwwhdgklbqz2vy9x4jg7cj3d6w6cpkndkcr7h0m5vz";
   };
 
   hardeningDisable = [ "pic" ];
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     description = "Driver for Realtek 802.11ac, rtl8812au, provides the 8812au mod";
-    homepage = "https://github.com/csssuf/rtl8812au";
+    homepage = "https://github.com/Grawp/rtl8812au_rtl8821au";
     license = stdenv.lib.licenses.gpl2;
     platforms = [ "x86_64-linux" "i686-linux" ];
     broken = (kernel.features.grsecurity or false);