summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-04-23 00:12:47 +0000
committerShea Levy <shea@shealevy.com>2012-04-23 00:12:47 +0000
commit50a0b839af5ca49075d268b93e4a94473ff4cfff (patch)
treedc2dad7b3df0e47bd397260e6a9b306e24825955 /pkgs/os-specific
parent50cab85e88ca3272179e6bf1f5e9927b2b5ec411 (diff)
downloadnixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar.gz
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar.bz2
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar.lz
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar.xz
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.tar.zst
nixlib-50a0b839af5ca49075d268b93e4a94473ff4cfff.zip
Linux 3.3.3
This incorporates the btrfs fix, so remove that patch. Also, I will test
that this builds after committing, and fix it if it fails

svn path=/nixpkgs/trunk/; revision=33885
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/btrfs-enospc.patch21
-rw-r--r--pkgs/os-specific/linux/kernel/linux-3.3.nix4
-rw-r--r--pkgs/os-specific/linux/kernel/patches.nix5
3 files changed, 2 insertions, 28 deletions
diff --git a/pkgs/os-specific/linux/kernel/btrfs-enospc.patch b/pkgs/os-specific/linux/kernel/btrfs-enospc.patch
deleted file mode 100644
index aebe285227de..000000000000
--- a/pkgs/os-specific/linux/kernel/btrfs-enospc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Revert of http://git.kernel.org/?p=linux/kernel/git/mason/linux-btrfs.git;a=commit;h=5500cdbe14d7435e04f66ff3cfb8ecd8b8e44ebf
-
-Btrfs mailing list where this patch comes from:
-http://article.gmane.org/gmane.comp.file-systems.btrfs/16650
-
-This change caused early ENOSPC, and should be integrated to some linux 3.3, but it is still
-not there. That's what #btrfs people say.
-
-diff --git a/fs/btrfs/extent-tree.c b/fs/btrfs/extent-tree.c
-index dc083f5..079e5a1 100644
---- a/fs/btrfs/extent-tree.c
-+++ b/fs/btrfs/extent-tree.c
-@@ -4108,7 +4108,7 @@ static u64 calc_global_metadata_size(struct btrfs_fs_info *fs_info)
- 	num_bytes += div64_u64(data_used + meta_used, 50);
- 
- 	if (num_bytes * 3 > meta_used)
--		num_bytes = div64_u64(meta_used, 3) * 2;
-+		num_bytes = div64_u64(meta_used, 3);
- 
- 	return ALIGN(num_bytes, fs_info->extent_root->leafsize << 10);
- }
diff --git a/pkgs/os-specific/linux/kernel/linux-3.3.nix b/pkgs/os-specific/linux/kernel/linux-3.3.nix
index 58038cb9203d..94e2d9e0dc64 100644
--- a/pkgs/os-specific/linux/kernel/linux-3.3.nix
+++ b/pkgs/os-specific/linux/kernel/linux-3.3.nix
@@ -233,7 +233,7 @@ in
 import ./generic.nix (
 
   rec {
-    version = "3.3.2";
+    version = "3.3.3";
     testing = false;
 
     preConfigure = ''
@@ -242,7 +242,7 @@ import ./generic.nix (
 
     src = fetchurl {
       url = "mirror://kernel/linux/kernel/v3.x/${if testing then "testing/" else ""}linux-${version}.tar.xz";
-      sha256 = "19paxvcs3bj32j5fp4ibx963la30p0331w7zvg3zcwmx0ml9pn9y";
+      sha256 = "1i0wxn40iwv4pl3azqq1dhzxi0sxfk4na3lrl9n8k5aip74yqyfb";
     };
 
     config = configWithPlatform stdenv.platform;
diff --git a/pkgs/os-specific/linux/kernel/patches.nix b/pkgs/os-specific/linux/kernel/patches.nix
index 9d4a6d001c4a..75f6473b57ba 100644
--- a/pkgs/os-specific/linux/kernel/patches.nix
+++ b/pkgs/os-specific/linux/kernel/patches.nix
@@ -359,9 +359,4 @@ rec {
       name = "guruplug-arch-number";
       patch = ./guruplug-mach-type.patch;
     };
-
-  btrfs_enospc =
-    { name = "btrfs-enospc-3.3-revert";
-      patch = ./btrfs-enospc.patch;
-    };
 }