summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-08-01 23:02:17 -0400
committerShea Levy <shea@shealevy.com>2012-08-01 23:02:17 -0400
commit4aba2bb3f509681ff98c68d837437f058cf3dccd (patch)
tree498af25b859e4737fd769e83b6c03cb14155df32 /pkgs/os-specific
parentec587dfc2596aa2c1e933c85016f1e29fe4ead16 (diff)
downloadnixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar.gz
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar.bz2
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar.lz
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar.xz
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.tar.zst
nixlib-4aba2bb3f509681ff98c68d837437f058cf3dccd.zip
linux/manual-config: Use kernelPatches like generic.nix, not a plain patches list
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index e2cee9c23e7c..6238509e8fa6 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -50,7 +50,7 @@ in
   # The kernel source (tarball, git checkout, etc.)
   src,
   # Any patches
-  patches ? [],
+  kernelPatches ? [],
   # The kernel .config file
   configfile,
   # Manually specified nixexpr representing the config
@@ -86,10 +86,12 @@ stdenv.mkDerivation {
   enableParallelBuilding = true;
 
   passthru = {
-    inherit version modDirVersion config;
+    inherit version modDirVersion config kernelPatches;
   };
 
-  inherit patches src;
+  inherit src;
+
+  patches = map (p: p.patch) kernelPatches;
 
   prePatch = ''
     for mf in $(find -name Makefile -o -name Makefile.include -o -name install.sh); do