summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorWill Dietz <github@wdtz.org>2018-11-02 04:04:13 -0500
committerGitHub <noreply@github.com>2018-11-02 04:04:13 -0500
commit467a822ac77c3d9488ca3e885384da591f6f58b9 (patch)
tree46717f63346de7c2e17da6ccfa6466642f9fdc97 /pkgs/os-specific
parentc417342cd21aa60202c0ab6f072ef1f470f850ef (diff)
parent5d616900ec910afa369f57139c64edb97d99fecd (diff)
downloadnixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar.gz
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar.bz2
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar.lz
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar.xz
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.tar.zst
nixlib-467a822ac77c3d9488ca3e885384da591f6f58b9.zip
Merge pull request #49495 from dtzWill/fix/thunderbolt-cleanup
thunderbolt: cleanup
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/thunderbolt/default.nix21
1 files changed, 6 insertions, 15 deletions
diff --git a/pkgs/os-specific/linux/thunderbolt/default.nix b/pkgs/os-specific/linux/thunderbolt/default.nix
index ac687de8c9ab..faf47c96a5e6 100644
--- a/pkgs/os-specific/linux/thunderbolt/default.nix
+++ b/pkgs/os-specific/linux/thunderbolt/default.nix
@@ -16,22 +16,13 @@ stdenv.mkDerivation rec {
     sha256 = "02w1bfm7xvq0dzkhwqiq0camkzz9kvciyhnsis61c8vzp39cwx0x";
   };
 
-  buildInputs = [
-    boost
-    cmake
-    pkgconfig
-    txt2tags
-  ];
+  nativeBuildInputs = [ cmake pkgconfig txt2tags ];
+  buildInputs = [ boost ];
 
-  # These can't go in the normal nix cmakeFlags because $out needs to be
-  # expanded by the shell, not by cmake or nix.  $ENV{out} doesn't work right
-  # either; it results in /build/source/build//nix/store/blahblahblahblah/bin/
-  # TODO: use ${placeholder "out"} when possible.
-  #       See https://github.com/NixOS/nixpkgs/pull/37693
-  preConfigure = ''
-    cmakeFlags+=" -DUDEV_BIN_DIR=$out/bin"
-    cmakeFlags+=" -DUDEV_RULES_DIR=$out/etc/udev/rules.d"
-  '';
+  cmakeFlags = [
+    "-DUDEV_BIN_DIR=${placeholder "out"}/bin"
+    "-DUDEV_RULES_DIR=${placeholder "out"}/etc/udev/rules.d"
+  ];
 
   meta = {
     description = "Thunderbolt(TM) user-space components";