summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-10-27 10:27:13 +0100
committerGitHub <noreply@github.com>2018-10-27 10:27:13 +0100
commit450d33fc5b04828af3b2527f6cc99f9189d80604 (patch)
tree6bd5ff1281583ab0c37f900395fc195f954e4ab0 /pkgs/os-specific
parent12764421b87d44ad8163ef0594d7959ff0db79fc (diff)
parentfcbaa7527d017b629c362cb4c9b1d65f86cb4bdc (diff)
downloadnixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar.gz
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar.bz2
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar.lz
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar.xz
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.tar.zst
nixlib-450d33fc5b04828af3b2527f6cc99f9189d80604.zip
Merge pull request #49081 from LnL7/darwin-wxmac
 wxmac: 3.0.2 -> 3.0.4 (darwin)
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/cf-private/default.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/pkgs/os-specific/darwin/cf-private/default.nix b/pkgs/os-specific/darwin/cf-private/default.nix
index 3fac20d23c78..dc1b0112a219 100644
--- a/pkgs/os-specific/darwin/cf-private/default.nix
+++ b/pkgs/os-specific/darwin/cf-private/default.nix
@@ -1,4 +1,4 @@
-{ CF, apple_sdk }:
+{ CF, apple_sdk, osx_private_sdk }:
 
 # cf-private is a bit weird, but boils down to CF with a weird setup-hook that
 # makes a build link against the system CoreFoundation rather than our pure one.
@@ -13,10 +13,10 @@
 # because of their magic "toll-free bridging" support, the symbols for those types
 # live in CoreFoundation with an ObjC runtime. And because that isn't public, we have
 # this hack in place to let people link properly anyway. Phew!
-# 
+#
 # This can be revisited if Apple ever decide to release the ObjC backend in a publicly
 # buildable form.
-# 
+#
 # This doesn't really need to rebuild CF, but it's cheap, and adding a setup hook to
 # an existing package was annoying. We need a buildEnv that knows how to add those
 CF.overrideAttrs (orig: {
@@ -38,22 +38,24 @@ CF.overrideAttrs (orig: {
   # this is watchman, who can almost certainly switch to the pure CF once the header
   # and functionality is merged in.
   installPhase = orig.installPhase + ''
+    # Copy or overwrite private headers, some of these might already
+    # exist in CF but the private versions have more information.
     basepath="Library/Frameworks/CoreFoundation.framework/Headers"
-    path="$basepath/CFFileDescriptor.h"
+    cp -Lfv --no-preserve mode ${osx_private_sdk}/include/CoreFoundationPrivateHeaders/* "$out/$basepath"
 
     # Append the include at top level or nobody will notice the header we're about to add
     sed -i '/CFNotificationCenter.h/a #include <CoreFoundation/CFFileDescriptor.h>' \
       "$out/$basepath/CoreFoundation.h"
 
-    cp ${apple_sdk.frameworks.CoreFoundation}/$path $out/$path
+    cp ${apple_sdk.frameworks.CoreFoundation}/$basepath/CFFileDescriptor.h $out/$basepath/CFFileDescriptor.h
   '' +
   # This one is less likely to go away, but I'll mention it anyway. The issue is at
   # https://bugs.swift.org/browse/SR-8744, and the main user I know of is qtbase
   ''
-    path="$basepath/CFURLEnumerator.h"    
+    path="$basepath/CFURLEnumerator.h"
     sed -i '/CFNotificationCenter.h/a #include <CoreFoundation/CFURLEnumerator.h>' \
       "$out/$basepath/CoreFoundation.h"
 
     cp ${apple_sdk.frameworks.CoreFoundation}/$path $out/$path
   '';
-})
\ No newline at end of file
+})