summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorDan Peebles <thetypesaretoobig@gmail.com>2015-02-08 23:36:19 -0500
committerDan Peebles <thetypesaretoobig@gmail.com>2015-02-08 23:36:19 -0500
commit3cb733779be3647d3b966c10dc5674498e7de1da (patch)
treedd1553185cd60cf3adc7155c6ecea09cc86b6d97 /pkgs/os-specific
parent794edf60cd62771ffcf9e3d82e5b26fba51ea5c4 (diff)
downloadnixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar.gz
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar.bz2
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar.lz
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar.xz
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.tar.zst
nixlib-3cb733779be3647d3b966c10dc5674498e7de1da.zip
Pretty sure nothing uses these, since they don't work (and we have a replacement in apple-source-releases)
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/libc/default.nix40
-rw-r--r--pkgs/os-specific/darwin/libc/fileport.patch38
2 files changed, 0 insertions, 78 deletions
diff --git a/pkgs/os-specific/darwin/libc/default.nix b/pkgs/os-specific/darwin/libc/default.nix
deleted file mode 100644
index 4d01434c3b9f..000000000000
--- a/pkgs/os-specific/darwin/libc/default.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ stdenv, fetchurl, fetchgit, fetchzip, perl, python }:
-
-let
-  osx_sdk = fetchgit {
-    url = "https://github.com/samdmarshall/OSXPrivateSDK";
-    rev = "refs/heads/master";
-    sha256 = "04m71xhjyac42h7alxjsqsipq07hm85wibvm3h65dqafcbqkl1i1";
-  };
-  dispatch = fetchzip {
-    url = "https://opensource.apple.com/tarballs/libdispatch/libdispatch-339.92.1.tar.gz";
-    sha256 = "0faxm4r7lamz57m9pr72jwm0qiwcrcy5dsiff0g9qyfi10pnj5i4";
-  };
-in
-stdenv.mkDerivation rec {
-  version = "825.40.1";
-  name = "libc-${version}";
-  src = fetchurl {
-    url = "https://opensource.apple.com/tarballs/Libc/Libc-${version}.tar.gz";
-    sha256 = "0xsx1im52gwlmcrv4lnhhhn9dyk5ci6g27k6yvibn9vj8fzjxwcf";
-  };
-
-  buildInputs = [ perl ];
-
-  patches = [ ./fileport.patch ];
-
-  configurePhase = ''
-    mkdir -p scratch
-    mkdir -p scratch/System/sys
-    ln -sv ${osx_sdk}/System/Library/Frameworks/System.framework/PrivateHeaders/sys/fsctl.h scratch/System/sys
-    mkdir tmpbin
-    ln -s /usr/bin/xcodebuild tmpbin
-    ln -s /usr/sbin/dtrace tmpbin
-    export PATH=$PATH:$(pwd -P)/tmpbin
-  '';
-
-  buildPhase = ''
-    BASE=$(pwd -P)
-    xcodebuild HEADER_SEARCH_PATHS="$BASE/fbsdcompat $BASE/pthreads $BASE/include $BASE/locale $BASE/locale/FreeBSD ${osx_sdk}/usr/local/include ${osx_sdk}/usr/include $BASE/stdtime/FreeBSD $BASE/gen ${osx_sdk}/System/Library/Frameworks/System.framework/PrivateHeaders $BASE/scratch ${osx_sdk}/System/Library/Frameworks/System.framework/PrivateHeaders/uuid $BASE/gdtoa"
-  '';
-}
diff --git a/pkgs/os-specific/darwin/libc/fileport.patch b/pkgs/os-specific/darwin/libc/fileport.patch
deleted file mode 100644
index 968b0da9d30f..000000000000
--- a/pkgs/os-specific/darwin/libc/fileport.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/Platforms/macosx/Makefile.inc b/Platforms/macosx/Makefile.inc
-index ff3617f..fdda58f 100644
---- a/Platforms/macosx/Makefile.inc
-+++ b/Platforms/macosx/Makefile.inc
-@@ -41,7 +41,7 @@ FEATURE_PATCH_3417676 = 1
- FEATURE_PATCH_5243343 = 1
- 
- # plockstat dtrace support
--FEATURE_PLOCKSTAT = 1
-+FEATURE_PLOCKSTAT = 0
- 
- # Timezone change notification
- FEATURE_TIMEZONE_CHANGE_NOTIFICATION = 1
-diff --git a/gen/asl.c b/gen/asl.c
-index 1948c92..53fce02 100644
---- a/gen/asl.c
-+++ b/gen/asl.c
-@@ -35,6 +35,7 @@
- #include <time.h>
- #include <sys/time.h>
- #include <sys/fcntl.h>
-+#include <sys/fileport.h>
- #include <crt_externs.h>
- #include <asl.h>
- #include <regex.h>
-diff --git a/locale/FreeBSD/toupper.c b/locale/FreeBSD/toupper.c
-index d02ddd6..e5a1f10 100644
---- a/locale/FreeBSD/toupper.c
-+++ b/locale/FreeBSD/toupper.c
-@@ -39,6 +39,8 @@ __FBSDID("$FreeBSD: src/lib/libc/locale/toupper.c,v 1.13 2007/01/09 00:28:01 imp
- #include <stdio.h>
- #include <runetype.h>
- 
-+#define __ct_rune_t ct_rune_t
-+
- __ct_rune_t
- ___toupper_l(c, loc)
- 	__ct_rune_t c;