summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 12:13:09 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 12:13:09 -0400
commit3befba542a4264c970de7fde63baa736900c8e53 (patch)
tree945abc1fe22f6d3455006244ae0de97fe6c2ee6c /pkgs/os-specific
parent3655e7e18bf7c2b7eeadf824d8c4230a487ca16e (diff)
parente92cda161ac9f0f0642536f079e39c482564e75e (diff)
downloadnixlib-3befba542a4264c970de7fde63baa736900c8e53.tar
nixlib-3befba542a4264c970de7fde63baa736900c8e53.tar.gz
nixlib-3befba542a4264c970de7fde63baa736900c8e53.tar.bz2
nixlib-3befba542a4264c970de7fde63baa736900c8e53.tar.lz
nixlib-3befba542a4264c970de7fde63baa736900c8e53.tar.xz
nixlib-3befba542a4264c970de7fde63baa736900c8e53.tar.zst
nixlib-3befba542a4264c970de7fde63baa736900c8e53.zip
Merge commit on master into staging
Doing this surgically so a future PR has a readable diff.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/ghc-standalone-archive/default.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
index d23328d362e0..227a8c59985c 100644
--- a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
+++ b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
@@ -2,8 +2,7 @@
 { haskellPackages, src, deps ? p : [], name }: let
   inherit (haskellPackages) ghc ghcWithPackages;
   with-env = ghcWithPackages deps;
-  crossPrefix = if (ghc.cross or null) != null then "${ghc.cross.config}-" else "";
-  ghcName = "${crossPrefix}ghc";
+  ghcName = "${ghc.prefix}ghc";
 in runCommand name { buildInputs = [ with-env cctools ]; } ''
   mkdir -p $out/lib
   mkdir -p $out/include