summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2017-11-22 00:42:06 +0900
committerVladimír Čunát <vcunat@gmail.com>2017-11-21 20:42:41 +0100
commit28f9262092d9a475c6c048f9d1aa460e97be2268 (patch)
treef466b4a784553e22958034f75964099b4826a788 /pkgs/os-specific
parent8e3b8a6c2adfbc47b7e9f00a819f1c0938b463d8 (diff)
downloadnixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar.gz
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar.bz2
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar.lz
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar.xz
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.tar.zst
nixlib-28f9262092d9a475c6c048f9d1aa460e97be2268.zip
kernel: improve modDirVersion error message
Now prints the current modDirVersion.  Close #31887.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index f922116ed36b..b0735e94619d 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -110,7 +110,7 @@ let
         make $makeFlags prepare
         actualModDirVersion="$(cat $buildRoot/include/config/kernel.release)"
         if [ "$actualModDirVersion" != "${modDirVersion}" ]; then
-          echo "Error: modDirVersion specified in the Nix expression is wrong, it should be: $actualModDirVersion"
+          echo "Error: modDirVersion ${modDirVersion} specified in the Nix expression is wrong, it should be: $actualModDirVersion"
           exit 1
         fi