summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-04-12 18:42:21 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2018-04-12 18:42:21 -0500
commit23467e207feb13d2ca783f0d36a21988e037507b (patch)
tree793aa9fdbe280eb77aa4d890dcee4a34c3df48aa /pkgs/os-specific
parent8287ba10fc7df5ae1cfcdd9057eb5e31f15a0824 (diff)
downloadnixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar.gz
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar.bz2
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar.lz
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar.xz
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.tar.zst
nixlib-23467e207feb13d2ca783f0d36a21988e037507b.zip
top: add meta
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/apple-source-releases/top/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/os-specific/darwin/apple-source-releases/top/default.nix b/pkgs/os-specific/darwin/apple-source-releases/top/default.nix
index f262d0c74732..4ddec2a30c90 100644
--- a/pkgs/os-specific/darwin/apple-source-releases/top/default.nix
+++ b/pkgs/os-specific/darwin/apple-source-releases/top/default.nix
@@ -1,4 +1,4 @@
-{xcbuild, appleDerivation, apple_sdk, ncurses, libutil-new}:
+{xcbuild, appleDerivation, apple_sdk, ncurses, libutil-new, lib}:
 
 appleDerivation {
   buildInputs = [ xcbuild apple_sdk.frameworks.IOKit ncurses libutil-new ];
@@ -8,4 +8,8 @@ appleDerivation {
     install -D Products/Release/libtop.h $out/include/libtop.h
     install -D Products/Release/top $out/bin/top
   '';
+  meta = {
+    platforms = lib.platforms.darwin;
+    maintainers = with lib.maintainers; [ matthewbauer ];
+  };
 }