summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-09-15 12:12:47 -0400
committerGitHub <noreply@github.com>2017-09-15 12:12:47 -0400
commit2295533f43e0ca801c3a90614db889128b0314bc (patch)
tree19d9c6bd7ec7e841e2e7348084c5dbc5ce6b7693 /pkgs/os-specific
parenta4633ca5a352af8eb01e5db48cd597a09397a776 (diff)
parente92cda161ac9f0f0642536f079e39c482564e75e (diff)
downloadnixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar.gz
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar.bz2
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar.lz
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar.xz
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.tar.zst
nixlib-2295533f43e0ca801c3a90614db889128b0314bc.zip
Merge pull request #29424 from obsidiansystems/slight-haskell-cleanup
haskell infra, ghc: Slight cleanup
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/ghc-standalone-archive/default.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
index d23328d362e0..227a8c59985c 100644
--- a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
+++ b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
@@ -2,8 +2,7 @@
 { haskellPackages, src, deps ? p : [], name }: let
   inherit (haskellPackages) ghc ghcWithPackages;
   with-env = ghcWithPackages deps;
-  crossPrefix = if (ghc.cross or null) != null then "${ghc.cross.config}-" else "";
-  ghcName = "${crossPrefix}ghc";
+  ghcName = "${ghc.prefix}ghc";
 in runCommand name { buildInputs = [ with-env cctools ]; } ''
   mkdir -p $out/lib
   mkdir -p $out/include