summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <subscribe@JohnEricson.me>2018-09-26 13:55:49 -0400
committerGitHub <noreply@github.com>2018-09-26 13:55:49 -0400
commit219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac (patch)
tree055c81de558f55f0015cdb5019e783e978b3b280 /pkgs/os-specific
parente2a20730115c0d36b4b56cdd03cff60f1cfdb369 (diff)
parent361521f5b0062d396dabe72b3f0ca0cdd31b8bf9 (diff)
downloadnixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar.gz
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar.bz2
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar.lz
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar.xz
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.tar.zst
nixlib-219a48f1ca1e52fc1b0b65cebe9b39a0cd9c59ac.zip
Merge pull request #47395 from obsidiansystems/paxctl-darwin
paxctl: Fix darwin and cross and use for linux cross
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/paxctl/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/paxctl/default.nix b/pkgs/os-specific/linux/paxctl/default.nix
index 270be695f03a..8fdd2356c30d 100644
--- a/pkgs/os-specific/linux/paxctl/default.nix
+++ b/pkgs/os-specific/linux/paxctl/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, stdenv }:
+{ fetchurl, stdenv, elf-header }:
 
 stdenv.mkDerivation rec {
   name = "paxctl-${version}";
@@ -9,8 +9,12 @@ stdenv.mkDerivation rec {
     sha256 = "0biw882fp1lmgs6kpxznp1v6758r7dg9x8iv5a06k0b82bcdsc53";
   };
 
+  buildInputs = [ elf-header ];
+
   preBuild = ''
-    sed "s|--owner 0 --group 0||g" -i Makefile
+    sed -i Makefile \
+      -e 's|--owner 0 --group 0||g' \
+      -e '/CC:=gcc/d'
   '';
 
   makeFlags = [
@@ -24,7 +28,7 @@ stdenv.mkDerivation rec {
     description = "A tool for controlling PaX flags on a per binary basis";
     homepage    = "https://pax.grsecurity.net";
     license     = licenses.gpl2;
-    platforms   = platforms.linux;
+    platforms   = platforms.all;
     maintainers = with maintainers; [ thoughtpolice ];
   };
 }