summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2011-07-24 20:24:23 +0000
committerShea Levy <shea@shealevy.com>2011-07-24 20:24:23 +0000
commit20ebca303e3372317c01c0c54f64f3d6423b094c (patch)
treee742d8aebc72fe2cd8307b38304d1d1ecc16e2fa /pkgs/os-specific
parent5db8c885470584789547c2b24544bcd98f758721 (diff)
downloadnixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar.gz
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar.bz2
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar.lz
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar.xz
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.tar.zst
nixlib-20ebca303e3372317c01c0c54f64f3d6423b094c.zip
Add comments explaining the purpose of the postBuild prepend
svn path=/nixpkgs/trunk/; revision=27922
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/generic.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/kernel/generic.nix b/pkgs/os-specific/linux/kernel/generic.nix
index 46ebb2b8fff4..b5d10f069211 100644
--- a/pkgs/os-specific/linux/kernel/generic.nix
+++ b/pkgs/os-specific/linux/kernel/generic.nix
@@ -77,6 +77,11 @@ stdenv.mkDerivation {
 
   inherit preConfigure src module_init_tools localVersion postInstall;
 
+  #Currently, the builder sets $MODULE_DIR during installPhase. This causes
+  #problems with at least linux 3.0, so we need to conditionally avoid
+  #setting $MODULE_DIR. This prepend to postBuild accomplishes this with a
+  #sed/eval trick thanks to MarcWeber
+
   postBuild = (if setModuleDir then "" else '' 
     eval "$(type installPhase | sed -e '1d' -e '/export MODULE_DIR/d')";
   '') + postBuild;