summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2013-11-13 05:58:15 -0600
committerBjørn Forsman <bjorn.forsman@gmail.com>2013-11-16 17:10:45 +0100
commit0eeb78d74c470b2d781ca46427e2614ae4313da5 (patch)
tree6654447dc5ecfb0db0cd9418f8b0f1c23372d58b /pkgs/os-specific
parentdb3abf1c45e4fbb1b41f6666d0b954249202c9c2 (diff)
downloadnixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar.gz
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar.bz2
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar.lz
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar.xz
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.tar.zst
nixlib-0eeb78d74c470b2d781ca46427e2614ae4313da5.zip
nvidia: Update to version 331.20
We no longer need the patches applied for the previous version so they
are removed.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/default.nix10
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/nvidia-drivers-linux-3.11-incremental.patch25
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/version-test.patch19
3 files changed, 3 insertions, 51 deletions
diff --git a/pkgs/os-specific/linux/nvidia-x11/default.nix b/pkgs/os-specific/linux/nvidia-x11/default.nix
index f9239bb5fba1..02eb65123d80 100644
--- a/pkgs/os-specific/linux/nvidia-x11/default.nix
+++ b/pkgs/os-specific/linux/nvidia-x11/default.nix
@@ -10,7 +10,7 @@ with stdenv.lib;
 
 let
 
-  versionNumber = "319.60";
+  versionNumber = "331.20";
 
 in
 
@@ -19,20 +19,16 @@ stdenv.mkDerivation {
 
   builder = ./builder.sh;
 
-  patches =
-    [ ./version-test.patch ]
-    ++ optional (!libsOnly && versionAtLeast kernelDev.version "3.11") ./nvidia-drivers-linux-3.11-incremental.patch;
-
   src =
     if stdenv.system == "i686-linux" then
       fetchurl {
         url = "http://us.download.nvidia.com/XFree86/Linux-x86/${versionNumber}/NVIDIA-Linux-x86-${versionNumber}.run";
-        sha256 = "0kjidkwd2b5aik74663mxk3ffq4a3fmaybq2aq1lcbfhvvh49j6j";
+        sha256 = "0icpmfsppnsvk7vj0fshi3ry4s1wix435s2c8wwak47765fv1mks";
       }
     else if stdenv.system == "x86_64-linux" then
       fetchurl {
         url = "http://us.download.nvidia.com/XFree86/Linux-x86_64/${versionNumber}/NVIDIA-Linux-x86_64-${versionNumber}-no-compat32.run";
-        sha256 = "0fhrxcfsw2jaycnz9gr04c9w585wydx8kpm6rjjbw19wkf8hlq3z";
+        sha256 = "02503dis3ngraqv7174a4pay2x08hp697n9q74rpjjclf5k74ax1";
       }
     else throw "nvidia-x11 does not support platform ${stdenv.system}";
 
diff --git a/pkgs/os-specific/linux/nvidia-x11/nvidia-drivers-linux-3.11-incremental.patch b/pkgs/os-specific/linux/nvidia-x11/nvidia-drivers-linux-3.11-incremental.patch
deleted file mode 100644
index bb6fad932e3c..000000000000
--- a/pkgs/os-specific/linux/nvidia-x11/nvidia-drivers-linux-3.11-incremental.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 8a8647ad942c8ac5161e1335f7f3e9dbb34dbf9e Mon Sep 17 00:00:00 2001
-From: Lukas Elsner <open@mindrunner.de>
-Date: Wed, 17 Jul 2013 01:16:04 +0200
-Subject: [PATCH] replace num_physpages with totalram_pages
-
----
- kernel/nv-linux.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/kernel/nv-linux.h b/kernel/nv-linux.h
-index 4e5ed89..46c51ec 100644
---- a/kernel/nv-linux.h
-+++ b/kernel/nv-linux.h
-@@ -957,7 +957,7 @@ static inline int nv_execute_on_all_cpus(void (*func)(void *info), void *info)
- #endif
- 
- #if !defined(NV_VMWARE)
--#define NV_NUM_PHYSPAGES                num_physpages
-+#define NV_NUM_PHYSPAGES                totalram_pages
- #define NV_GET_CURRENT_PROCESS()        current->tgid
- #define NV_IN_ATOMIC()                  in_atomic()
- #define NV_LOCAL_BH_DISABLE()           local_bh_disable()
--- 
-1.8.3.2
-
diff --git a/pkgs/os-specific/linux/nvidia-x11/version-test.patch b/pkgs/os-specific/linux/nvidia-x11/version-test.patch
deleted file mode 100644
index 9b6908ee5c0a..000000000000
--- a/pkgs/os-specific/linux/nvidia-x11/version-test.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur NVIDIA-Linux-x86_64-310.32-no-compat32/kernel/conftest.sh NVIDIA-patched/kernel/conftest.sh
---- NVIDIA-Linux-x86_64-310.32-no-compat32/kernel/conftest.sh	2013-01-14 18:11:17.000000000 -0430
-+++ NVIDIA-patched/kernel/conftest.sh	2013-02-05 14:44:50.757999124 -0430
-@@ -1699,11 +1699,13 @@
-                 # kernel older than 2.6.6, that's all we require to
-                 # build the module.
-                 #
-+                VERSION=$(grep "^VERSION =" $MAKEFILE | cut -d " " -f 3)
-                 PATCHLEVEL=$(grep "^PATCHLEVEL =" $MAKEFILE | cut -d " " -f 3)
-                 SUBLEVEL=$(grep "^SUBLEVEL =" $MAKEFILE | cut -d " " -f 3)
- 
--                if [ -n "$PATCHLEVEL" -a $PATCHLEVEL -ge 6 \
--                        -a -n "$SUBLEVEL" -a $SUBLEVEL -le 5 ]; then
-+                if [ -n "$VERSION" -a -n "$PATCHLEVEL" -a -n "$SUBLEVEL" \
-+                     -a "$VERSION" -ge 3 -o "$VERSION" -eq 2 -a "$PATCHLEVEL" -ge 7 \
-+                     -o "$PATCHLEVEL" -eq 6 -a "$SUBLEVEL" -ge 6 ]; then 
-                     SELECTED_MAKEFILE=Makefile.kbuild
-                     RET=0
-                 fi