summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-05-22 13:30:20 -0400
committerGitHub <noreply@github.com>2017-05-22 13:30:20 -0400
commit0d88299019bcd0611ec7356e7e380d9706f09f9d (patch)
treefdcabf9744f1169270a06e5b170ee00a6d9b9d4c /pkgs/os-specific
parent37c89aaaa7948574529e05a88d42d5343d1053c9 (diff)
parent1dc6f15de995da2d0351b34c40215336e219cf82 (diff)
downloadnixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar.gz
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar.bz2
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar.lz
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar.xz
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.tar.zst
nixlib-0d88299019bcd0611ec7356e7e380d9706f09f9d.zip
Merge pull request #25976 from obsidiansystems/no-stdenv-is
Add `*Platform.is*` predicates and alias `stdenv.is*` to `hostPlatform`'s
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/cctools/port.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/pkgs/os-specific/darwin/cctools/port.nix b/pkgs/os-specific/darwin/cctools/port.nix
index 14c4c6e99739..222c51603fdd 100644
--- a/pkgs/os-specific/darwin/cctools/port.nix
+++ b/pkgs/os-specific/darwin/cctools/port.nix
@@ -5,17 +5,15 @@
 }:
 
 let
-  inherit (stdenv.lib.systems.parse) isDarwin;
-
   prefix = stdenv.lib.optionalString
     (targetPlatform != hostPlatform)
     "${targetPlatform.config}-";
 in
 
-assert isDarwin targetPlatform.parsed;
+assert targetPlatform.isDarwin;
 
 # Non-Darwin alternatives
-assert (!isDarwin hostPlatform.parsed) -> (maloader != null && xctoolchain != null);
+assert (!hostPlatform.isDarwin) -> (maloader != null && xctoolchain != null);
 
 let
   baseParams = rec {
@@ -91,7 +89,7 @@ let
     '';
 
     postInstall =
-      if isDarwin hostPlatform.parsed
+      if hostPlatform.isDarwin
       then ''
         cat >$out/bin/dsymutil << EOF
         #!${stdenv.shell}