summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2017-02-06 15:47:20 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2017-02-06 15:49:34 +0100
commit0d422c5db5aba204b6886fe199eda1834bbc97a1 (patch)
tree2a6f4a07429ef56a9550f88a5fcad51a8fd7d847 /pkgs/os-specific
parent6eb6130e15b72d12537989655ecebd9d7a5451a3 (diff)
downloadnixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar.gz
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar.bz2
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar.lz
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar.xz
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.tar.zst
nixlib-0d422c5db5aba204b6886fe199eda1834bbc97a1.zip
grsecurity: 4.8.17-201701151620 -> 4.9.8-201702060653
The first release in the 4.9 branch.

I've also migrated my update scripts to SHA-512 so that'll
be the hash of choice for grsec packages going forward.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/linux-grsecurity.nix6
-rw-r--r--pkgs/os-specific/linux/kernel/patches.nix10
2 files changed, 8 insertions, 8 deletions
diff --git a/pkgs/os-specific/linux/kernel/linux-grsecurity.nix b/pkgs/os-specific/linux/kernel/linux-grsecurity.nix
index ebeb47397bca..5640aa80576f 100644
--- a/pkgs/os-specific/linux/kernel/linux-grsecurity.nix
+++ b/pkgs/os-specific/linux/kernel/linux-grsecurity.nix
@@ -1,12 +1,12 @@
 { stdenv, fetchurl, perl, buildLinux, ... } @ args:
 
 import ./generic.nix (args // rec {
-  version = "4.8.17";
-  extraMeta.branch = "4.8";
+  version = "4.9.8";
+  extraMeta.branch = "4.9";
 
   src = fetchurl {
     url = "mirror://kernel/linux/kernel/v4.x/linux-${version}.tar.xz";
-    sha256 = "1zk0q6bvqgz2pk1axd5z0cx71vqk96314f1zn8apwa4raylf9fpa";
+    sha512 = "39r4hq5f70nc1v8qq4qvnd0fq98h4akm6y6zp7ml6mi5knz7v6zm86ykq87a0ph3zh23msimi4155354qcsmsxp4cbd22cq8s1w86ds";
   };
 
   kernelPatches = args.kernelPatches;
diff --git a/pkgs/os-specific/linux/kernel/patches.nix b/pkgs/os-specific/linux/kernel/patches.nix
index 4848057547eb..d4c0b20e9b8d 100644
--- a/pkgs/os-specific/linux/kernel/patches.nix
+++ b/pkgs/os-specific/linux/kernel/patches.nix
@@ -18,7 +18,7 @@ let
       };
     };
 
-  grsecPatch = { grbranch ? "test", grver ? "3.1", kver, grrev, sha256 }: rec {
+  grsecPatch = { grbranch ? "test", grver ? "3.1", kver, grrev, sha512 }: rec {
     name = "grsecurity-${grver}-${kver}-${grrev}";
 
     # Pass these along to allow the caller to determine compatibility
@@ -32,7 +32,7 @@ let
         # source files immediately upon releasing a new version ...
         "https://raw.githubusercontent.com/slashbeast/grsecurity-scrape/master/${grbranch}/${kver}/${name}.patch"
       ];
-      inherit sha256;
+      inherit sha512;
     };
 
     features.grsecurity = true;
@@ -95,9 +95,9 @@ rec {
   };
 
   grsecurity_testing = grsecPatch
-    { kver   = "4.8.17";
-      grrev  = "201701151620";
-      sha256 = "10gavcdby8aiylbx8afc1x4j0vzbb16bhlw39a7ibnav45scsr0p";
+    { kver   = "4.9.8";
+      grrev  = "201702060653";
+      sha512 = "1kammx0q0v37xw9z9zk7ppkixrwlr866dpfykjs4wy3ypcivnvkbk7dimyihna3vrylwgp5gq90ly7dj7d9gdblh83ccnq6n2m7ba43";
     };
 
   # This patch relaxes grsec constraints on the location of usermode helpers,