summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-04-12 19:15:01 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-04-12 19:15:47 -0400
commit01e1722e8fe932106d65bc87b83e5684534fa6e6 (patch)
treeffb8a1372441556f2980a5b433ed5b409ba25ce0 /pkgs/os-specific
parent175d4ab1db65088c008e667f0423efbf325c179f (diff)
downloadnixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar.gz
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar.bz2
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar.lz
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar.xz
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.tar.zst
nixlib-01e1722e8fe932106d65bc87b83e5684534fa6e6.zip
cctools: Make assert meta.broken instead
This more politely expresses the same thing
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/cctools/port.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/pkgs/os-specific/darwin/cctools/port.nix b/pkgs/os-specific/darwin/cctools/port.nix
index bcca11d66b19..0eef47ed6dfe 100644
--- a/pkgs/os-specific/darwin/cctools/port.nix
+++ b/pkgs/os-specific/darwin/cctools/port.nix
@@ -12,8 +12,6 @@ let
     "${targetPlatform.config}-";
 in
 
-assert targetPlatform.isDarwin;
-
 # Non-Darwin alternatives
 assert (!hostPlatform.isDarwin) -> (maloader != null && xctoolchain != null);
 
@@ -117,6 +115,7 @@ let
     };
 
     meta = {
+      broken = !targetPlatform.isDarwin; # Only supports darwin targets
       homepage = http://www.opensource.apple.com/source/cctools/;
       description = "MacOS Compiler Tools (cross-platform port)";
       license = stdenv.lib.licenses.apsl20;