summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-03-28 15:16:29 +0000
committerRobin Gloster <mail@glob.in>2016-03-28 15:16:29 +0000
commitf60c9df0ba66767dfa64bf2fb95eb6776cafa2c3 (patch)
tree0f17999d3a5444f16f09e0c1d7f3075e0224e731 /pkgs/misc
parent3f45f0948d6fe158bed063adb66850ded0ba4861 (diff)
parentc61445357e2a92470bee43a71a10baef1a3196e4 (diff)
downloadnixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar.gz
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar.bz2
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar.lz
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar.xz
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.tar.zst
nixlib-f60c9df0ba66767dfa64bf2fb95eb6776cafa2c3.zip
Merge remote-tracking branch 'upstream/master' into hardened-stdenv
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/drivers/brgenml1cupswrapper/default.nix105
-rw-r--r--pkgs/misc/cups/drivers/brgenml1lpr/default.nix93
-rw-r--r--pkgs/misc/cups/drivers/mfcj470dw/default.nix17
-rw-r--r--pkgs/misc/cups/drivers/splix/default.nix20
-rw-r--r--pkgs/misc/cups/drivers/splix/splix-2.0.0-gcc45.patch18
-rw-r--r--pkgs/misc/emulators/higan/0001-change-flags.diff9
-rw-r--r--pkgs/misc/emulators/mednaffe/default.nix28
-rw-r--r--pkgs/misc/lilypond/default.nix2
-rw-r--r--pkgs/misc/vim-plugins/default.nix18
-rw-r--r--pkgs/misc/vim-plugins/vim-plugin-names1
-rw-r--r--pkgs/misc/vim-plugins/vim2nix/additional-nix-code/youcompleteme2
11 files changed, 268 insertions, 45 deletions
diff --git a/pkgs/misc/cups/drivers/brgenml1cupswrapper/default.nix b/pkgs/misc/cups/drivers/brgenml1cupswrapper/default.nix
new file mode 100644
index 000000000000..e4ac510dd148
--- /dev/null
+++ b/pkgs/misc/cups/drivers/brgenml1cupswrapper/default.nix
@@ -0,0 +1,105 @@
+{ stdenv, fetchurl, cups, perl, brgenml1lpr, debugLvl ? "0"}:
+
+/*
+    [Setup instructions](http://support.brother.com/g/s/id/linux/en/instruction_prn1a.html).
+
+    URI example
+     ~  `lpd://BRW0080927AFBCE/binary_p1`
+
+    Logging
+    -------
+    
+    `/tmp/br_cupswrapper_ml1.log` when `DEBUG > 0` in `brother_lpdwrapper_BrGenML1`.
+    Note that when `DEBUG > 1` the wrapper stops performing its function. Better
+    keep `DEBUG == 1` unless this is desirable.
+
+    Now activable through this package's `debugLvl` parameter whose value is to be
+    used to establish `DEBUG`.
+
+    Issues
+    ------
+
+     1.  >  Error: /tmp/brBrGenML1rc_15642 :cannot open file !!
+
+        This is a non fatal issue. The job will still be printed. However, not sure
+        what kind of information could be lost.
+
+        There should be a more elegant way to patch this.
+
+     2.  >  touch: cannot touch '/tmp/BrGenML1_latest_print_info': Permission denied
+
+        TODO: Address.
+
+     3.  >  perl: warning: Falling back to the standard locale ("C").
+    
+            are supported and installed on your system.
+            LANG = "en_US.UTF-8"
+            LC_ALL = (unset),
+            LANGUAGE = (unset),
+            perl: warning: Please check that your locale settings:
+            perl: warning: Setting locale failed.
+
+        TODO: Address.
+*/
+
+stdenv.mkDerivation rec {
+
+  name = "brgenml1cupswrapper-3.1.0-1";
+  src = fetchurl {
+    url = "http://download.brother.com/welcome/dlf101125/${name}.i386.deb";
+    sha256 = "0kd2a2waqr10kfv1s8is3nd5dlphw4d1343srdsbrlbbndja3s6r";
+  };
+
+  unpackPhase = ''
+    ar x $src
+    tar xfvz data.tar.gz
+  '';
+
+  buildInputs = [ cups perl brgenml1lpr ];
+  buildPhase = ":";
+
+  patchPhase = ''
+    WRAPPER=opt/brother/Printers/BrGenML1/cupswrapper/brother_lpdwrapper_BrGenML1
+    PAPER_CFG=opt/brother/Printers/BrGenML1/cupswrapper/paperconfigml1  
+
+    substituteInPlace $WRAPPER \
+      --replace "basedir =~" "basedir = \"${brgenml1lpr}/opt/brother/Printers/BrGenML1\"; #" \
+      --replace "PRINTER =~" "PRINTER = \"BrGenML1\"; #" \
+      --replace "\$DEBUG=0;" "\$DEBUG=${debugLvl};"
+
+    # Fixing issue #2.
+    substituteInPlace $WRAPPER \
+      --replace "\`cp " "\`cp -p " \
+      --replace "\$TEMPRC\`" "\$TEMPRC; chmod a+rw \$TEMPRC\`" \
+      --replace "\`mv " "\`cp -p "
+
+    # This config script make this assumption that the *.ppd are found in a global location `/etc/cups/ppd`.
+    substituteInPlace $PAPER_CFG \
+      --replace "/etc/cups/ppd" "$out/share/cups/model"
+  '';
+
+  installPhase = ''
+    CUPSFILTER=$out/lib/cups/filter
+    CUPSPPD=$out/share/cups/model
+
+    CUPSWRAPPER=opt/brother/Printers/BrGenML1/cupswrapper
+    mkdir -p $out/$CUPSWRAPPER
+    cp -rp $CUPSWRAPPER/* $out/$CUPSWRAPPER
+
+    mkdir -p $CUPSFILTER
+    ln -s $out/$CUPSWRAPPER/brother_lpdwrapper_BrGenML1 $CUPSFILTER
+
+    mkdir -p $CUPSPPD
+    ln -s $out/$CUPSWRAPPER/brother-BrGenML1-cups-en.ppd $CUPSPPD
+  '';
+
+  dontPatchELF = true;
+
+  meta = {
+    description = "Brother BrGenML1 CUPS wrapper driver";
+    homepage = http://www.brother.com;
+    platforms = stdenv.lib.platforms.linux;
+    license = stdenv.lib.licenses.gpl2Plus;
+    maintainers = with stdenv.lib.maintainers; [ jraygauthier ];
+  };
+}
diff --git a/pkgs/misc/cups/drivers/brgenml1lpr/default.nix b/pkgs/misc/cups/drivers/brgenml1lpr/default.nix
new file mode 100644
index 000000000000..6dc2408ec88a
--- /dev/null
+++ b/pkgs/misc/cups/drivers/brgenml1lpr/default.nix
@@ -0,0 +1,93 @@
+{ stdenv, fetchurl, cups, perl, glibc, ghostscript, which, makeWrapper}:
+
+/*
+    [Setup instructions](http://support.brother.com/g/s/id/linux/en/instruction_prn1a.html).
+
+    URI example
+     ~  `lpd://BRW0080927AFBCE/binary_p1`
+
+    Logging
+    -------
+    
+    `/tmp/br_lpdfilter_ml1.log` when `$ENV{LPD_DEBUG} > 0` in `filter_BrGenML1`
+    which is activated automatically when `DEBUG > 0` in `brother_lpdwrapper_BrGenML1`
+    from the cups wrapper.
+
+    Issues
+    ------
+
+     -  filter_BrGenML1 ln 196 `my $GHOST_SCRIPT=`which gs`;`
+      
+        `GHOST_SCRIPT` is empty resulting in an empty `/tmp/br_lpdfilter_ml1_gsout.dat` file.
+        See `/tmp/br_lpdfilter_ml1.log` for the executed command.
+
+    Notes
+    -----
+
+     -  The `setupPrintcap` has totally no use in our context.
+*/
+
+let
+  myPatchElf = file: with stdenv.lib; ''
+    patchelf --set-interpreter \
+      ${stdenv.glibc}/lib/ld-linux${optionalString stdenv.is64bit "-x86-64"}.so.2 \
+      ${file}
+  '';
+in
+stdenv.mkDerivation rec {
+
+  name = "brgenml1lpr-3.1.0-1";
+  src = fetchurl {
+    url = "http://download.brother.com/welcome/dlf101123/${name}.i386.deb";
+    sha256 = "0zdvjnrjrz9sba0k525linxp55lr4cyivfhqbkq1c11br2nvy09f";
+  };
+
+  unpackPhase = ''
+    ar x $src
+    tar xfvz data.tar.gz
+  '';
+
+  nativeBuildInputs = [ makeWrapper ];
+  buildInputs = [ cups perl glibc ghostscript which ];
+  
+  buildPhase = ":";
+
+  patchPhase = ''
+    INFDIR=opt/brother/Printers/BrGenML1/inf
+    LPDDIR=opt/brother/Printers/BrGenML1/lpd
+
+    # Setup max debug log by default.
+    substituteInPlace $LPDDIR/filter_BrGenML1 \
+      --replace "BR_PRT_PATH =~" "BR_PRT_PATH = \"$out/opt/brother/Printers/BrGenML1\"; #" \
+      --replace "PRINTER =~" "PRINTER = \"BrGenML1\"; #"
+
+    ${myPatchElf "$INFDIR/braddprinter"}
+    ${myPatchElf "$LPDDIR/brprintconflsr3"}
+    ${myPatchElf "$LPDDIR/rawtobr3"}
+  '';
+
+  installPhase = ''
+    INFDIR=opt/brother/Printers/BrGenML1/inf
+    LPDDIR=opt/brother/Printers/BrGenML1/lpd
+
+    mkdir -p $out/$INFDIR
+    cp -rp $INFDIR/* $out/$INFDIR
+    mkdir -p $out/$LPDDIR
+    cp -rp $LPDDIR/* $out/$LPDDIR
+
+    wrapProgram $out/$LPDDIR/filter_BrGenML1 \
+      --prefix PATH ":" "${ghostscript}/bin" \
+      --prefix PATH ":" "${which}/bin"
+  '';
+
+  dontPatchELF = true;
+
+
+  meta = {
+    description = "Brother BrGenML1 LPR driver";
+    homepage = http://www.brother.com;
+    platforms = stdenv.lib.platforms.linux;
+    license = stdenv.lib.licenses.gpl2Plus;
+    maintainers = with stdenv.lib.maintainers; [ jraygauthier ];
+  };
+}
diff --git a/pkgs/misc/cups/drivers/mfcj470dw/default.nix b/pkgs/misc/cups/drivers/mfcj470dw/default.nix
index d1a1b239371a..d6ce3fbcdc64 100644
--- a/pkgs/misc/cups/drivers/mfcj470dw/default.nix
+++ b/pkgs/misc/cups/drivers/mfcj470dw/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, cups, dpkg, ghostscript, patchelf, bash, file }:
+{ stdenv, fetchurl, cups, dpkg, ghostscript, patchelf, a2ps, coreutils, gnused, gawk, file }:
 
 stdenv.mkDerivation rec {
   name = "mfcj470dw-cupswrapper-${version}";
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
       })
     ];
 
-  buildInputs = [ dpkg cups patchelf bash ];
+    buildInputs = [ cups ghostscript dpkg a2ps ];
 
   unpackPhase = "true";
 
@@ -29,9 +29,20 @@ stdenv.mkDerivation rec {
 
     substituteInPlace $out/opt/brother/Printers/mfcj470dw/lpd/filtermfcj470dw \
       --replace /opt "$out/opt" \
-      --replace file "/run/current-system/sw/bin/file"
+      --replace file "${file}/bin/file" \
+      --replace sed "${gnused}/bin/sed" \
+      --replace mktemp "${coreutils}/bin/mktemp" \
+      --replace cat "${coreutils}/bin/cat" \
+      --replace rm "${coreutils}/bin/rm"
 
     sed -i '/GHOST_SCRIPT=/c\GHOST_SCRIPT=gs' $out/opt/brother/Printers/mfcj470dw/lpd/psconvertij2
+    substituteInPlace $out/opt/brother/Printers/mfcj470dw/lpd/psconvertij2 \
+      --replace awk "${gawk}/bin/awk" \
+      --replace cat "${coreutils}/bin/cat" \
+      --replace mktemp "${coreutils}/bin/mktemp" \
+      --replace sed "${gnused}/bin/sed" \
+      --replace expr "${coreutils}/bin/expr" \
+      --replace rm "${coreutils}/bin/rm"
 
     patchelf --set-interpreter ${stdenv.glibc}/lib/ld-linux.so.2 $out/opt/brother/Printers/mfcj470dw/lpd/brmfcj470dwfilter
     patchelf --set-interpreter ${stdenv.glibc}/lib/ld-linux.so.2 $out/opt/brother/Printers/mfcj470dw/cupswrapper/brcupsconfpt1
diff --git a/pkgs/misc/cups/drivers/splix/default.nix b/pkgs/misc/cups/drivers/splix/default.nix
index 532ef2a45d5d..9a924e044d7f 100644
--- a/pkgs/misc/cups/drivers/splix/default.nix
+++ b/pkgs/misc/cups/drivers/splix/default.nix
@@ -1,16 +1,16 @@
-{stdenv, fetchurl, cups, zlib}:
-
+{ stdenv, fetchsvn, fetchurl, cups, zlib }:
+let rev = "315"; in
 stdenv.mkDerivation rec {
-  name = "splix-2.0.0";
-
-  src = fetchurl {
-    url = "mirror://sourceforge/splix/${name}.tar.bz2";
-    sha256 = "0bwivrwwvh6hzvnycpzqs7a0capgycahc4s3v9ihx552fgy07xwp";
+  name = "splix-svn-${rev}";
+  src = fetchsvn {
+    # We build this from svn, because splix hasn't been in released in several years
+    # although the community has been adding some new printer models.
+    url = "svn://svn.code.sf.net/p/splix/code/splix";
+    rev = "r${rev}";
+    sha256 = "16wbm4xnz35ca3mw2iggf5f4jaxpyna718ia190ka6y4ah932jxl";
   };
 
-  patches = [ ./splix-2.0.0-gcc45.patch ];
-
-  preBuild=''
+  preBuild = ''
     makeFlags="V=1 DISABLE_JBIG=1 CUPSFILTER=$out/lib/cups/filter CUPSPPD=$out/share/cups/model"
   '';
 
diff --git a/pkgs/misc/cups/drivers/splix/splix-2.0.0-gcc45.patch b/pkgs/misc/cups/drivers/splix/splix-2.0.0-gcc45.patch
deleted file mode 100644
index 5ccdcb2514c5..000000000000
--- a/pkgs/misc/cups/drivers/splix/splix-2.0.0-gcc45.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Fixing build with gcc 4.5
-
-http://bugs.gentoo.org/show_bug.cgi?id=318581
-
-downloaded from
-http://gentoo-overlays.zugaina.org/gentoo/portage/net-print/splix/files/splix-2.0.0-gcc45.patch
-
---- splix-old/src/ppdfile.cpp
-+++ splix-new/src/ppdfile.cpp
-@@ -282,7 +282,7 @@
-  * Opérateur d'assignation
-  * Assignment operator
-  */
--void PPDFile::Value::operator = (const PPDFile::Value::Value &val)
-+void PPDFile::Value::operator = (const PPDFile::Value &val)
- {
-     if (_preformatted)
-         delete[] _preformatted;
diff --git a/pkgs/misc/emulators/higan/0001-change-flags.diff b/pkgs/misc/emulators/higan/0001-change-flags.diff
index 78f4a248c5fd..9d7608b93281 100644
--- a/pkgs/misc/emulators/higan/0001-change-flags.diff
+++ b/pkgs/misc/emulators/higan/0001-change-flags.diff
@@ -11,15 +11,6 @@ diff -rupN higan_v095-source.orig/GNUmakefile higan_v095-source/GNUmakefile
  objects := libco
  
  # profile-guided optimization mode
-@@ -43,7 +44,7 @@ ifeq ($(platform),windows)
- else ifeq ($(platform),macosx)
-   flags += -march=native
- else ifeq ($(platform),linux)
--  flags += -march=native -fopenmp
-+  flags += -fopenmp
-   link += -fopenmp
-   link += -Wl,-export-dynamic
-   link += -lX11 -lXext -ldl
 diff -rupN higan_v095-source.orig/icarus/GNUmakefile higan_v095-source/icarus/GNUmakefile
 --- higan_v095-source.orig/icarus/GNUmakefile	2015-11-04 10:28:26.186486119 +0100
 +++ higan_v095-source/icarus/GNUmakefile	2015-11-04 10:28:48.755059317 +0100
diff --git a/pkgs/misc/emulators/mednaffe/default.nix b/pkgs/misc/emulators/mednaffe/default.nix
new file mode 100644
index 000000000000..7777e73d3375
--- /dev/null
+++ b/pkgs/misc/emulators/mednaffe/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, pkgconfig, gtk2, mednafen }:
+
+stdenv.mkDerivation rec {
+
+  version = "0.8";
+  name = "mednaffe-${version}";
+
+  src = fetchFromGitHub {
+	repo = "mednaffe";
+	owner = "AmatCoder";
+	rev = "v${version}";
+	sha256 = "1j4py4ih14fa6dv0hka03rs4mq19ir83qkbxsz3695a4phmip0jr";
+  };
+
+  prePatch = ''
+    substituteInPlace src/mednaffe.c --replace "binpath = NULL" "binpath = \"${mednafen}/bin/mednafen\""
+  '';
+
+  buildInputs = [ pkgconfig gtk2 mednafen ];
+
+  meta = with stdenv.lib; {
+    description = "A GTK based frontend for mednafen";
+    homepage = https://github.com/AmatCoder/mednaffe;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.sheenobu ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/misc/lilypond/default.nix b/pkgs/misc/lilypond/default.nix
index 8b2be0914e3e..731dc263a022 100644
--- a/pkgs/misc/lilypond/default.nix
+++ b/pkgs/misc/lilypond/default.nix
@@ -30,6 +30,8 @@ stdenv.mkDerivation rec{
     # confused the version detection…
     sed -re 's%("[$]exe" --version .*)([|\\] *$)%\1 | sed -re "s@/nix/store/[a-z0-9]{32}-@@" \2%' \
       -i configure
+
+    export HOME=$TMPDIR/home
   '';
 
   postInstall = ''
diff --git a/pkgs/misc/vim-plugins/default.nix b/pkgs/misc/vim-plugins/default.nix
index f1e64a8e6f3c..fa09d1ca92b9 100644
--- a/pkgs/misc/vim-plugins/default.nix
+++ b/pkgs/misc/vim-plugins/default.nix
@@ -883,11 +883,11 @@ rec {
   };
 
   youcompleteme = buildVimPluginFrom2Nix { # created by nix#NixDerivation
-    name = "youcompleteme-2016-03-08";
+    name = "youcompleteme-2016-03-10";
     src = fetchgit {
       url = "git://github.com/valloric/youcompleteme";
-      rev = "381b2132719a959f41e57ec0e6396fc1c3b6daf4";
-      sha256 = "1gski3s1960pmxisyq85awda0a3kb22ji9y76f67k1a4smy5q9xa";
+      rev = "f44435b88ec98156d17869aa67ad15f38cfecbf3";
+      sha256 = "1y50ilyfwj6rvpvg50iq418maxvsfs54i202v7x0lfs5hmvcb4hi";
     };
     dependencies = [];
     buildInputs = [
@@ -904,7 +904,7 @@ rec {
       mkdir build
       pushd build
       cmake -G "Unix Makefiles" . ../third_party/ycmd/cpp -DPYTHON_LIBRARIES:PATH=${python}/lib/libpython2.7.so -DPYTHON_INCLUDE_DIR:PATH=${python}/include/python2.7 -DUSE_CLANG_COMPLETER=ON -DUSE_SYSTEM_LIBCLANG=ON
-      make ycm_support_libs -j''${NIX_BUILD_CORES} -l''${NIX_BUILD_CORES}}
+      make ycm_core -j''${NIX_BUILD_CORES} -l''${NIX_BUILD_CORES}}
       ${python}/bin/python ../third_party/ycmd/build.py --gocode-completer --clang-completer --system-libclang
       popd
     '';
@@ -1451,6 +1451,16 @@ rec {
 
   };
 
+  vim-airline-themes = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "vim-airline-themes-2016-02-24";
+    src = fetchgit {
+      url = "git://github.com/vim-airline/vim-airline-themes";
+      rev = "13bad30d4ee3892cae755c83433ee85fbc96d028";
+      sha256 = "0w36ani4r2v58pd0fcqv12j0hjd97g2q78zici1a72njvwp9qhgj";
+    };
+    dependencies = [ "vim-airline" ];
+  };
+
   vim-coffee-script = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "vim-coffee-script-2015-04-20";
     src = fetchgit {
diff --git a/pkgs/misc/vim-plugins/vim-plugin-names b/pkgs/misc/vim-plugins/vim-plugin-names
index 82b59f1ebaa8..88e9bbb95944 100644
--- a/pkgs/misc/vim-plugins/vim-plugin-names
+++ b/pkgs/misc/vim-plugins/vim-plugin-names
@@ -112,6 +112,7 @@
 "vim-addon-toggle-buffer"
 "vim-addon-xdebug"
 "vim-airline"
+"vim-airline-themes"
 "vim-coffee-script"
 "vim-easy-align"
 "vim-gista"
diff --git a/pkgs/misc/vim-plugins/vim2nix/additional-nix-code/youcompleteme b/pkgs/misc/vim-plugins/vim2nix/additional-nix-code/youcompleteme
index 48f5322267b8..cb90adfdc397 100644
--- a/pkgs/misc/vim-plugins/vim2nix/additional-nix-code/youcompleteme
+++ b/pkgs/misc/vim-plugins/vim2nix/additional-nix-code/youcompleteme
@@ -12,7 +12,7 @@
       mkdir build
       pushd build
       cmake -G "Unix Makefiles" . ../third_party/ycmd/cpp -DPYTHON_LIBRARIES:PATH=${python}/lib/libpython2.7.so -DPYTHON_INCLUDE_DIR:PATH=${python}/include/python2.7 -DUSE_CLANG_COMPLETER=ON -DUSE_SYSTEM_LIBCLANG=ON
-      make ycm_support_libs -j''${NIX_BUILD_CORES} -l''${NIX_BUILD_CORES}}
+      make ycm_core -j''${NIX_BUILD_CORES} -l''${NIX_BUILD_CORES}}
       ${python}/bin/python ../third_party/ycmd/build.py --gocode-completer --clang-completer --system-libclang
       popd
     '';