summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-10-07 10:16:36 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-10-07 10:17:42 +0200
commitef41fc7f5140a6d980faf7ed2a865ec2f092253b (patch)
tree81bcfcc47155b56618dd73934ba41d8d8c7fc309 /pkgs/misc
parent656a0089f68495cd42d3164ed85d22ceec630d82 (diff)
parent893df17c5a37e14616a24e66d96f3fd5e0344bce (diff)
downloadnixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar.gz
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar.bz2
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar.lz
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar.xz
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.tar.zst
nixlib-ef41fc7f5140a6d980faf7ed2a865ec2f092253b.zip
Merge branch 'master' into staging
Hydra: ?compare=1399476
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/mednafen/default.nix42
-rw-r--r--pkgs/misc/emulators/mednafen/server.nix12
-rw-r--r--pkgs/misc/emulators/wine/base.nix2
-rw-r--r--pkgs/misc/emulators/wine/sources.nix6
4 files changed, 32 insertions, 30 deletions
diff --git a/pkgs/misc/emulators/mednafen/default.nix b/pkgs/misc/emulators/mednafen/default.nix
index a03695eed772..1172a89caf32 100644
--- a/pkgs/misc/emulators/mednafen/default.nix
+++ b/pkgs/misc/emulators/mednafen/default.nix
@@ -1,36 +1,42 @@
-{ stdenv, fetchurl, pkgconfig
-, libX11, mesa, freeglut
-, libjack2, libcdio, libsndfile, libsamplerate
-, SDL, SDL_net, zlib
-}:
+{ stdenv, fetchurl, pkgconfig, freeglut, mesa, libcdio, libjack2
+, libsamplerate, libsndfile, libX11, SDL, SDL_net, zlib }:
 
-with stdenv.lib;
 stdenv.mkDerivation rec {
-
   name = "mednafen-${version}";
-  version = "0.9.47";
+  version = "0.9.48";
 
   src = fetchurl {
     url = "https://mednafen.github.io/releases/files/${name}.tar.xz";
-    sha256 = "0flz6bjkzs9qrw923s4cpqrz4b2dhc2w7pd8mgw0l1xbmrh7w4si";
+    sha256 = "00i12mywhp43274aq466fwavglk5b7d8z8bfdna12ra9iy1hrk6k";
   };
 
-  buildInputs =
-  [ pkgconfig libX11 mesa freeglut libjack2 libcdio
-    libsndfile libsamplerate SDL SDL_net zlib ];
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [
+    freeglut
+    mesa
+    libcdio
+    libjack2
+    libsamplerate
+    libsndfile
+    libX11
+    SDL
+    SDL_net
+    zlib
+  ];
+
+  hardeningDisable = [ "pic" ];
 
-  # Install docs
   postInstall = ''
-    mkdir -p $out/share/doc/$name
-    cd Documentation
-    install -m 644 -t $out/share/doc/$name *.css *.def *.html *.php *.png *.txt
+    mkdir -p $out/share/doc
+    mv Documentation $out/share/doc/mednafen
   '';
 
   meta = with stdenv.lib; {
     description = "A portable, CLI-driven, SDL+OpenGL-based, multi-system emulator";
-    homepage = http://mednafen.github.io/;
+    homepage = https://mednafen.github.io/;
     license = licenses.gpl2;
-    maintainers = [ maintainers.AndersonTorres ];
+    maintainers = with maintainers; [ AndersonTorres ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/misc/emulators/mednafen/server.nix b/pkgs/misc/emulators/mednafen/server.nix
index 91a74171da9a..75eeeea4c008 100644
--- a/pkgs/misc/emulators/mednafen/server.nix
+++ b/pkgs/misc/emulators/mednafen/server.nix
@@ -1,25 +1,21 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-
   name = "mednafen-server-${version}";
   version = "0.5.2";
 
   src = fetchurl {
-    url = "https://mednafen.github.io/releases/files/mednafen-server-0.5.2.tar.xz";
+    url = "https://mednafen.github.io/releases/files/mednafen-server-${version}.tar.xz";
     sha256 = "0xm7dj5nwnrsv69r72rcnlw03jm0l8rmrg3s05gjfvxyqmlb36dq";
   };
 
-  postInstall = ''
-    mkdir -p $out/share/$name
-    install -m 644 -t $out/share/$name standard.conf
-  '';
+  postInstall = "install -m 644 -Dt $out/share/mednafen-server standard.conf";
 
   meta = with stdenv.lib; {
     description = "Netplay server for Mednafen";
-    homepage = http://mednafen.github.io/;
+    homepage = https://mednafen.github.io/;
     license = licenses.gpl2;
-    maintainers = [ maintainers.AndersonTorres ];
+    maintainers = with maintainers; [ AndersonTorres ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/misc/emulators/wine/base.nix b/pkgs/misc/emulators/wine/base.nix
index 9fb90875b976..0f59892cce1e 100644
--- a/pkgs/misc/emulators/wine/base.nix
+++ b/pkgs/misc/emulators/wine/base.nix
@@ -34,7 +34,7 @@ stdenv.mkDerivation ((lib.optionalAttrs (! isNull buildScript) {
   ++ lib.optional cairoSupport           pkgs.cairo
   ++ lib.optional tiffSupport            pkgs.libtiff
   ++ lib.optional odbcSupport            pkgs.unixODBC
-  ++ lib.optional netapiSupport          pkgs.samba3_light
+  ++ lib.optional netapiSupport          pkgs.samba4
   ++ lib.optional cursesSupport          pkgs.ncurses
   ++ lib.optional vaSupport              pkgs.libva-full
   ++ lib.optional pcapSupport            pkgs.libpcap
diff --git a/pkgs/misc/emulators/wine/sources.nix b/pkgs/misc/emulators/wine/sources.nix
index aaaec67c751e..fb384aee746e 100644
--- a/pkgs/misc/emulators/wine/sources.nix
+++ b/pkgs/misc/emulators/wine/sources.nix
@@ -32,15 +32,15 @@ in rec {
 
   unstable = fetchurl rec {
     # NOTE: Don't forget to change the SHA256 for staging as well.
-    version = "2.17";
+    version = "2.18";
     url = "https://dl.winehq.org/wine/source/2.x/wine-${version}.tar.xz";
-    sha256 = "0sgazjn30ki2y3bjrd0xbpf870ii22wkyrmgaxcwbk23j1rrbp3y";
+    sha256 = "0l2gmk6g4c5ds29iqcvpmh5g8jdz6g6id7xkgiqps5bqk09322cz";
     inherit (stable) mono gecko32 gecko64;
   };
 
   staging = fetchFromGitHub rec {
     inherit (unstable) version;
-    sha256 = "11jm39g1kc77fvn02j9g8syyc095b6w2jashyr28v4gi7g0fqv6h";
+    sha256 = "02rh2lvx7sd8d6nhgpfq9crjh495k4k7i3wmgigs4m5rlip363s8";
     owner = "wine-compholio";
     repo = "wine-staging";
     rev = "v${version}";