summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2014-10-18 14:02:40 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2014-10-20 17:45:27 +0200
commite6c1973971cde736b3649e752f0705a7c2b9d0c5 (patch)
treec29272b1096cd637a2c66f8fdf00c72ba1a76fe2 /pkgs/misc
parent5165ee6ff33258cc909ae48f959ca1cc2536b132 (diff)
downloadnixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar.gz
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar.bz2
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar.lz
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar.xz
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.tar.zst
nixlib-e6c1973971cde736b3649e752f0705a7c2b9d0c5.zip
vim-plugins: update source hash for command-t
And use fetchzip instead of fetchurl towards github.com to not let this
happen again. (fetchzip checks the hash on the *extracted* archive, so
changes in compression algo etc. doesn't change the hash.)
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/misc/vim-plugins/default.nix b/pkgs/misc/vim-plugins/default.nix
index dce0cbf66855..33595cab6c06 100644
--- a/pkgs/misc/vim-plugins/default.nix
+++ b/pkgs/misc/vim-plugins/default.nix
@@ -1,4 +1,4 @@
-{ fetchurl, bash, stdenv, python, cmake, vim, perl, ruby, unzip, which, fetchgit, clang }:
+{ fetchurl, bash, stdenv, python, cmake, vim, perl, ruby, unzip, which, fetchgit, fetchzip, clang }:
 
 /*
 About Vim and plugins
@@ -172,9 +172,10 @@ in rec
   command_T = buildVimPlugin rec {
     version = "1.8";
     name = "command-t-${version}";
-    src = fetchurl {
+    src = fetchzip {
+      inherit name;
       url    = "https://github.com/wincent/Command-T/archive/${version}.tar.gz";
-      sha256 = "ad8664292e6eee40fbe195d856d20d93a8630e8c0149317ad72cc39423630800";
+      sha256 = "186qz1smf7w91r68p724whg6d821f7ph6ks63l2vkhff8f9qqhrc";
     };
     buildInputs = [ perl ruby ];
     buildPhase = ''