summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorYochai <yochai@titat.info>2016-03-18 11:22:48 +0200
committerYochai <yochai@titat.info>2016-03-18 19:56:27 +0200
commite6b85e6b787f8e253e54698d65fd8184e543bc32 (patch)
tree263604608bfc6cd625589157dcbdaa23a1fafbaf /pkgs/misc
parentdaa03b0229ea77c34530cbadf60b4126a979fae5 (diff)
downloadnixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar.gz
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar.bz2
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar.lz
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar.xz
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.tar.zst
nixlib-e6b85e6b787f8e253e54698d65fd8184e543bc32.zip
mfcj470dw: fix missing file error
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/drivers/mfcj470dw/default.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/pkgs/misc/cups/drivers/mfcj470dw/default.nix b/pkgs/misc/cups/drivers/mfcj470dw/default.nix
index d1a1b239371a..d6ce3fbcdc64 100644
--- a/pkgs/misc/cups/drivers/mfcj470dw/default.nix
+++ b/pkgs/misc/cups/drivers/mfcj470dw/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, cups, dpkg, ghostscript, patchelf, bash, file }:
+{ stdenv, fetchurl, cups, dpkg, ghostscript, patchelf, a2ps, coreutils, gnused, gawk, file }:
 
 stdenv.mkDerivation rec {
   name = "mfcj470dw-cupswrapper-${version}";
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
       })
     ];
 
-  buildInputs = [ dpkg cups patchelf bash ];
+    buildInputs = [ cups ghostscript dpkg a2ps ];
 
   unpackPhase = "true";
 
@@ -29,9 +29,20 @@ stdenv.mkDerivation rec {
 
     substituteInPlace $out/opt/brother/Printers/mfcj470dw/lpd/filtermfcj470dw \
       --replace /opt "$out/opt" \
-      --replace file "/run/current-system/sw/bin/file"
+      --replace file "${file}/bin/file" \
+      --replace sed "${gnused}/bin/sed" \
+      --replace mktemp "${coreutils}/bin/mktemp" \
+      --replace cat "${coreutils}/bin/cat" \
+      --replace rm "${coreutils}/bin/rm"
 
     sed -i '/GHOST_SCRIPT=/c\GHOST_SCRIPT=gs' $out/opt/brother/Printers/mfcj470dw/lpd/psconvertij2
+    substituteInPlace $out/opt/brother/Printers/mfcj470dw/lpd/psconvertij2 \
+      --replace awk "${gawk}/bin/awk" \
+      --replace cat "${coreutils}/bin/cat" \
+      --replace mktemp "${coreutils}/bin/mktemp" \
+      --replace sed "${gnused}/bin/sed" \
+      --replace expr "${coreutils}/bin/expr" \
+      --replace rm "${coreutils}/bin/rm"
 
     patchelf --set-interpreter ${stdenv.glibc}/lib/ld-linux.so.2 $out/opt/brother/Printers/mfcj470dw/lpd/brmfcj470dwfilter
     patchelf --set-interpreter ${stdenv.glibc}/lib/ld-linux.so.2 $out/opt/brother/Printers/mfcj470dw/cupswrapper/brcupsconfpt1