summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2011-02-17 16:33:39 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2011-02-17 16:33:39 +0000
commitd6c6f9f0e05d0701eb74c65e2068eef58ea06307 (patch)
treea66c6774e9e863405b50246d4f3eb30f425c907a /pkgs/misc
parent7d44982534c5899fcb3fa45f5916d837c54c8537 (diff)
parent0970ed2f9ba3f832694b0e1edda0f33a862aac80 (diff)
downloadnixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar.gz
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar.bz2
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar.lz
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar.xz
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.tar.zst
nixlib-d6c6f9f0e05d0701eb74c65e2068eef58ea06307.zip
* Sync with the trunk.
svn path=/nixpkgs/branches/x-updates/; revision=26018
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/ghostscript/default.nix2
-rw-r--r--pkgs/misc/ghostscript/pstoraster.patch81
-rw-r--r--pkgs/misc/themes/gtk2/oxygen-gtk/default.nix11
3 files changed, 88 insertions, 6 deletions
diff --git a/pkgs/misc/ghostscript/default.nix b/pkgs/misc/ghostscript/default.nix
index e1201fd08b85..053b7a0acfc2 100644
--- a/pkgs/misc/ghostscript/default.nix
+++ b/pkgs/misc/ghostscript/default.nix
@@ -37,7 +37,7 @@ stdenv.mkDerivation rec {
 
   CFLAGS = "-fPIC";
 
-  patches = [ ./purity.patch ./urw-font-files.patch ];
+  patches = [ ./purity.patch ./urw-font-files.patch ./pstoraster.patch];
 
   doCheck = true;
 
diff --git a/pkgs/misc/ghostscript/pstoraster.patch b/pkgs/misc/ghostscript/pstoraster.patch
new file mode 100644
index 000000000000..465c91e4f19e
--- /dev/null
+++ b/pkgs/misc/ghostscript/pstoraster.patch
@@ -0,0 +1,81 @@
+Upstream issue: http://bugs.ghostscript.com/show_bug.cgi?id=691108
+e.g. printing a test page prints only black
+
+Patch: https://bugs.archlinux.org/task/18339
+
+--- a/cups/gdevcups.c
++++ b/cups/gdevcups.c
+@@ -975,7 +975,8 @@ cups_map_cmyk(gx_device *pdev,		/* I - Device info */
+ 	      frac      k,		/* I - Black value */
+ 	      frac      *out)		/* O - Device colors */
+ {
+-  int	c0, c1, c2, c3;			/* Temporary color values */
++  int	c0 = 0, c1 = 0,
++        c2 = 0, c3 = 0;			/* Temporary color values */
+   float	rr, rg, rb,			/* Real RGB colors */
+ 	ciex, ciey, ciez,		/* CIE XYZ colors */
+ 	ciey_yn,			/* Normalized luminance */
+@@ -2703,9 +2704,13 @@ cups_put_params(gx_device     *pdev,	/* I - Device info */
+   int			color_set;	/* Were the color attrs set? */
+   gdev_prn_space_params	sp;		/* Space parameter data */
+   int			width,		/* New width of page */
+-                        height;		/* New height of page */
++                        height,		/* New height of page */
++                        colorspace,     /* New color space */
++                        bitspercolor;   /* New bits per color */
+   static int            width_old = 0,  /* Previous width */
+-                        height_old = 0; /* Previous height */
++                        height_old = 0, /* Previous height */
++                        colorspace_old = 0,/* Previous color space */
++                        bitspercolor_old = 0;/* Previous bits per color */
+   ppd_attr_t            *backside = NULL,
+                         *backsiderequiresflippedmargins = NULL;
+   float                 swap;
+@@ -2800,9 +2805,10 @@ cups_put_params(gx_device     *pdev,	/* I - Device info */
+   else if (code == 0) \
+   { \
+     dprintf1("DEBUG: Setting %s to", sname); \
+-    for (i = 0; i < count; i ++) \
+-      dprintf1(" %d", (unsigned)(arrayval.data[i]));	 \
+-      cups->header.name[i] = (unsigned)arrayval.data[i]; \
++    for (i = 0; i < count; i ++) { \
++      dprintf1(" %d", (unsigned)(arrayval.data[i])); \
++      cups->header.name[i] = (unsigned)(arrayval.data[i]); \
++    } \
+     dprintf("...\n"); \
+   }
+ 
+@@ -3243,23 +3249,31 @@ cups_put_params(gx_device     *pdev,	/* I - Device info */
+     }
+ #endif /* CUPS_RASTER_SYNCv1 */
+ 
++    colorspace = cups->header.cupsColorSpace;
++    bitspercolor = cups->header.cupsBitsPerColor;
++
+    /*
+     * Don't reallocate memory unless the device has been opened...
+     * Also reallocate only if the size has actually changed...
+     */
+ 
+-    if (pdev->is_open && (width != width_old || height != height_old))
++    if (pdev->is_open &&
++	(width != width_old || height != height_old ||
++	 colorspace != colorspace_old || bitspercolor != bitspercolor_old))
+     {
+ 
+       width_old = width;
+       height_old = height;
++      colorspace_old = colorspace;
++      bitspercolor_old = bitspercolor;
+ 
+      /*
+       * Device is open and size has changed, so reallocate...
+       */
+ 
+-      dprintf4("DEBUG2: Reallocating memory, [%.0f %.0f] = %dx%d pixels...\n",
+-	       pdev->MediaSize[0], pdev->MediaSize[1], width, height);
++      dprintf6("DEBUG2: Reallocating memory, [%.0f %.0f] = %dx%d pixels, color space: %d, bits per color: %d...\n",
++	       pdev->MediaSize[0], pdev->MediaSize[1], width, height,
++	       colorspace, bitspercolor);
+ 
+       sp = ((gx_device_printer *)pdev)->space_params;
\ No newline at end of file
diff --git a/pkgs/misc/themes/gtk2/oxygen-gtk/default.nix b/pkgs/misc/themes/gtk2/oxygen-gtk/default.nix
index 608be713dd26..7679d0ead368 100644
--- a/pkgs/misc/themes/gtk2/oxygen-gtk/default.nix
+++ b/pkgs/misc/themes/gtk2/oxygen-gtk/default.nix
@@ -2,19 +2,20 @@
   cmake, glib, gtk, pkgconfig }:
 
 stdenv.mkDerivation rec {
-  name = "oxygen-gtk";
   version = "1.0.1";
-  
+  name = "oxygen-gtk-${version}";  
+
   src = fetchurl {
-    url = "mirror://kde/stable/${name}/${version}/src/${name}-${version}.tar.bz2";
+    url = "mirror://kde/stable/oxygen-gtk/${version}/src/${name}.tar.bz2";
     sha256 = "0ki8qllr5ai48bl2pz8rxzf5cax08ckhgrn0nlf815ba83jfar32";
   };
   
   buildInputs = [ cmake glib gtk pkgconfig ];
   
-  meta = {
+  meta = with stdenv.lib; {
     description = "Port of the default KDE widget theme (Oxygen), to gtk";
     homepage = https://projects.kde.org/projects/playground/artwork/oxygen-gtk;
-    licence = "LGPLv2";
+    license = licenses.lgpl2;
+    maintainers = [ maintainers.goibhniu ];
   };
 }