summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-12-17 20:39:58 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-12-17 20:39:58 +0000
commitb48b2a7bb4add41c33f680df0117e3c92cc0515b (patch)
tree2f7451135e2dd9619e142529c4672d0317b12312 /pkgs/misc
parente60ba9135a90808a3443d09fbd92f2259e9deea8 (diff)
parenta6f1f87697768e39c5ed7f1e475b3002e1418d46 (diff)
downloadnixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar.gz
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar.bz2
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar.lz
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar.xz
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.tar.zst
nixlib-b48b2a7bb4add41c33f680df0117e3c92cc0515b.zip
Merging from trunk. I solved some trivial merge conflicts.
svn path=/nixpkgs/branches/stdenv-updates/; revision=25188
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/default.nix10
-rw-r--r--pkgs/misc/cups/pdf-filter.nix43
2 files changed, 49 insertions, 4 deletions
diff --git a/pkgs/misc/cups/default.nix b/pkgs/misc/cups/default.nix
index 2c363ed80d5c..73fa3c37f39a 100644
--- a/pkgs/misc/cups/default.nix
+++ b/pkgs/misc/cups/default.nix
@@ -1,17 +1,17 @@
 { stdenv, fetchurl, pkgconfig, zlib, libjpeg, libpng, libtiff, pam, openssl
-, dbus, libusb }:
+, dbus, libusb, acl }:
 
-let version = "1.4.4"; in
+let version = "1.4.5"; in
 
 stdenv.mkDerivation {
   name = "cups-${version}";
 
   src = fetchurl {
     url = "http://ftp.easysw.com/pub/cups/${version}/cups-${version}-source.tar.bz2";
-    md5 = "8776403ad60fea9e85eab9c04d88560d";
+    sha256 = "1zhf3hvx11i0qnbwyybmdhx4fxkxfd4ch69k59fj5bz8wvcdcl04";
   };
 
-  buildInputs = [ pkgconfig zlib libjpeg libpng libtiff pam dbus libusb ];
+  buildInputs = [ pkgconfig zlib libjpeg libpng libtiff pam dbus libusb acl ];
 
   propagatedBuildInputs = [ openssl ];
 
@@ -39,5 +39,7 @@ stdenv.mkDerivation {
     homepage = http://www.cups.org/;
     description = "A standards-based printing system for UNIX";
     license = "GPLv2"; # actually LGPL for the library and GPL for the rest
+    maintainers = [ stdenv.lib.maintainers.urkud ];
+    platforms = stdenv.lib.platforms.linux;
   };
 }
diff --git a/pkgs/misc/cups/pdf-filter.nix b/pkgs/misc/cups/pdf-filter.nix
new file mode 100644
index 000000000000..ab978068e175
--- /dev/null
+++ b/pkgs/misc/cups/pdf-filter.nix
@@ -0,0 +1,43 @@
+{ stdenv, fetchurl, pkgconfig, cups, poppler }:
+
+let version = "1.4.5"; in
+
+stdenv.mkDerivation {
+  name = "cups-pdf-filter-${version}";
+
+  src = fetchurl {
+    url = "http://ftp.easysw.com/pub/cups/${version}/cups-${version}-source.tar.bz2";
+    sha256 = "1zhf3hvx11i0qnbwyybmdhx4fxkxfd4ch69k59fj5bz8wvcdcl04";
+  };
+
+  buildInputs = [ pkgconfig cups poppler ];
+
+  preConfigure = ''
+    sed -e 's@\.\./cups/$(LIBCUPS)@@' -e 's@$(LIBCUPSIMAGE)@@' -i filter/Makefile
+    ''; 
+
+  NIX_LDFLAGS="-L${cups}/lib";
+
+  configureFlags = ''
+    --localstatedir=/var --enable-dbus
+    --enable-image --with-pdftops=pdftops'';
+
+  buildPhase = ''
+    cd filter
+    make pdftops
+    '';
+
+  installPhase = ''
+    mkdir -pv $out/lib/cups/filter
+    cp -v pdftops $out/lib/cups/filter
+    '';
+
+
+  meta = {
+    homepage = http://www.cups.org/;
+    description = "Image and pdf filters for CUPS";
+    license = "GPLv2";
+    maintainers = [ stdenv.lib.maintainers.urkud ];
+    platforms = stdenv.lib.platforms.linux;
+  };
+}