summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-11-19 08:30:14 +0000
committerOrivej Desh <orivej@gmx.fr>2017-11-19 08:30:14 +0000
commitb089c2150675f1e8bbcf5117b484b9047d44b3f8 (patch)
tree7fec2823f80ca5143013eda5175fc867eee6407c /pkgs/misc
parentc76890f2fe24ca64bc216515149f7316080912f0 (diff)
parenta1573bbbb297f89af5ac26bb7141e1c4524d592c (diff)
downloadnixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar.gz
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar.bz2
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar.lz
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar.xz
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.tar.zst
nixlib-b089c2150675f1e8bbcf5117b484b9047d44b3f8.zip
Merge branch 'master' into staging
* master: (39 commits)
  python.pkgs.pybfd: move to python-modules
  documentation: python 2.6 is no more
  documentation: python3Packages is python36Packages
  wireguard: 0.0.20171101 -> 0.0.20171111
  php_excel: init at 1.0.2
  libxl: init at 3.8.1
  matrix-synapse: 0.24.1 -> 0.25.1
  grafana: 4.6.1 -> 4.6.2
  linux: 4.4.98 -> 4.4.99
  linux: 4.9.62 -> 4.9.63
  linux: 4.13.13 -> 4.13.14
  nixos/zsh: add the type for enableAutosuggestions option
  zsh-powerlevel9k: init at 2017-11-10
  fio: 3.1 -> 3.2
  filebench: rehash source
  nano: 2.8.7 -> 2.9.0
  bonnie: replace dead source link
  less: 520 -> 529
  strace: 4.19 -> 4.20
  iperf: 3.2 -> 3.3
  ...
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/uboot/default.nix29
1 files changed, 23 insertions, 6 deletions
diff --git a/pkgs/misc/uboot/default.nix b/pkgs/misc/uboot/default.nix
index a69bf2ceac7b..1947fd30a401 100644
--- a/pkgs/misc/uboot/default.nix
+++ b/pkgs/misc/uboot/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, bc, dtc, python2
+{ stdenv, fetchurl, fetchpatch, bc, dtc, python2
 , hostPlatform
 }:
 
@@ -12,21 +12,38 @@ let
            stdenv.mkDerivation (rec {
 
     name = "uboot-${defconfig}-${version}";
-    version = "2017.03";
+    version = "2017.11";
 
     src = fetchurl {
       url = "ftp://ftp.denx.de/pub/u-boot/u-boot-${version}.tar.bz2";
-      sha256 = "0gqihplap05dlpwdb971wsqyv01nz2vabwq5g5649gr5jczsyjzm";
+      sha256 = "01bcsah5imy6m3fbjwhqywxg0pfk5fl8ks9ylb7kv3zmrb9qy0ba";
     };
 
-    nativeBuildInputs = [ bc dtc python2 ];
-
-    hardeningDisable = [ "all" ];
+    patches = [
+      (fetchpatch {
+        url = https://github.com/dezgeg/u-boot/commit/rpi-2017-11-patch1.patch;
+        sha256 = "067yq55vv1slv4xy346px7h329pi14abdn04chg6s1s6hmf6c1x9";
+      })
+      (fetchpatch {
+        url = https://github.com/dezgeg/u-boot/commit/rpi-2017-11-patch2.patch;
+        sha256 = "0bbw0q027xvzvdxxvpzjajg4rm30a8mb7z74b6ma9q0l7y7bi0c4";
+      })
+      (fetchpatch {
+        url = https://github.com/dezgeg/u-boot/commit/pythonpath-2017-11.patch;
+        sha256 = "162b2lglp307pzxsf9m7nnmzwxqd7xkwp5j85bm6bg1a38ngpl9v";
+      })
+    ];
 
     postPatch = ''
       patchShebangs tools
     '';
 
+    nativeBuildInputs = [ bc dtc python2 ];
+
+    hardeningDisable = [ "all" ];
+
+    makeFlags = [ "DTC=dtc" ];
+
     configurePhase = ''
       make ${defconfig}
     '';