summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-12-28 19:20:09 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-12-28 19:20:09 +0100
commitab3eeabfeddacf3e159e68ee1541a6281a1e9d1b (patch)
tree8070852a5ee331104a06de5395d30223185f936a /pkgs/misc
parent5be0a9acd7b9abe4bff3202a7ac7defc17a37877 (diff)
downloadnixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar.gz
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar.bz2
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar.lz
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar.xz
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.tar.zst
nixlib-ab3eeabfeddacf3e159e68ee1541a6281a1e9d1b.zip
Rename buildNativeInputs -> nativeBuildInputs
Likewise for propagatedBuildNativeInputs, etc.  "buildNativeInputs"
sounds like an imperative rather than a noun phrase.
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/my-env/default.nix6
-rw-r--r--pkgs/misc/uboot/default.nix2
-rw-r--r--pkgs/misc/uboot/guruplug.nix2
-rw-r--r--pkgs/misc/uboot/sheevaplug.nix2
4 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/misc/my-env/default.nix b/pkgs/misc/my-env/default.nix
index 19c105bf4f02..85499e893f8e 100644
--- a/pkgs/misc/my-env/default.nix
+++ b/pkgs/misc/my-env/default.nix
@@ -63,8 +63,8 @@
 
 mkDerivation {
   # The setup.sh script from stdenv will expect the native build inputs in
-  # the buildNativeInputs environment variable.
-  buildNativeInputs = [ ] ++ buildInputs;
+  # the nativeBuildInputs environment variable.
+  nativeBuildInputs = [ ] ++ buildInputs;
   # Trick to bypass the stdenv usual change of propagatedBuildInputs => propagatedNativeBuildInputs
   propagatedBuildInputs2 = propagatedBuildInputs;
 
@@ -87,7 +87,7 @@ mkDerivation {
         -e 's@trap.*@@' \
         -i "$s"
     cat >> "$out/dev-envs/''${name/env-/}" << EOF
-      buildNativeInputs="$buildNativeInputs"
+      nativeBuildInputs="$nativeBuildInputs"
       propagatedBuildInputs="$propagatedBuildInputs2"
       # the setup-new script wants to write some data to a temp file.. so just let it do that and tidy up afterwards
       tmp="\$("${pkgs.coreutils}/bin/mktemp" -d)"
diff --git a/pkgs/misc/uboot/default.nix b/pkgs/misc/uboot/default.nix
index 7525c28e740e..74379880706f 100644
--- a/pkgs/misc/uboot/default.nix
+++ b/pkgs/misc/uboot/default.nix
@@ -27,7 +27,7 @@ stdenv.mkDerivation {
     sha256 = "1rld7q3ww89si84g80hqskd1z995lni5r5xc4d4322n99wqiarh6";
   };
 
-  buildNativeInputs = [ unzip ];
+  nativeBuildInputs = [ unzip ];
 
   dontStrip = true;
 
diff --git a/pkgs/misc/uboot/guruplug.nix b/pkgs/misc/uboot/guruplug.nix
index 0e63a56073b6..b1f4cab7b735 100644
--- a/pkgs/misc/uboot/guruplug.nix
+++ b/pkgs/misc/uboot/guruplug.nix
@@ -39,7 +39,7 @@ stdenv.mkDerivation {
     fi
   '';
 
-  buildNativeInputs = [ unzip ];
+  nativeBuildInputs = [ unzip ];
 
   dontStrip = true;
 
diff --git a/pkgs/misc/uboot/sheevaplug.nix b/pkgs/misc/uboot/sheevaplug.nix
index ad8029d90203..4d4f61c40a70 100644
--- a/pkgs/misc/uboot/sheevaplug.nix
+++ b/pkgs/misc/uboot/sheevaplug.nix
@@ -42,7 +42,7 @@ stdenv.mkDerivation {
     fi
   '';
 
-  buildNativeInputs = [ unzip ];
+  nativeBuildInputs = [ unzip ];
 
   dontStrip = true;