summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-03-15 08:15:22 -0400
committerShea Levy <shea@shealevy.com>2014-03-15 08:15:22 -0400
commita330e244ad60e50def988115643b7e42bf46cf58 (patch)
treebd0529e9ccb4570ef87b9465b6f1e0464e479491 /pkgs/misc
parentec0116f99d47f3ae08b843b6a48eb2973c4b0ca1 (diff)
downloadnixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar.gz
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar.bz2
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar.lz
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar.xz
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.tar.zst
nixlib-a330e244ad60e50def988115643b7e42bf46cf58.zip
Revert "Merge branch 'nix-run' of git://github.com/rickynils/nixpkgs"
nix-run's functionality is subsumed by nix-shell -p.

This reverts commit 3cc2b243c7f2d906ce77968e75fd84a3f65a09e0, reversing
changes made to 4d5d6aed29a0ee10a471fd870fa2fdb61408e4eb.
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/nix-run/default.nix72
1 files changed, 0 insertions, 72 deletions
diff --git a/pkgs/misc/nix-run/default.nix b/pkgs/misc/nix-run/default.nix
deleted file mode 100644
index ef83ec2a1f3d..000000000000
--- a/pkgs/misc/nix-run/default.nix
+++ /dev/null
@@ -1,72 +0,0 @@
-{ stdenv, bash, writeScript }:
-
-let
-
-  nix-run = writeScript "nix-run" ''
-    #!${bash}/bin/bash
-
-    # Runs nix-build and executes the result
-    # All arguments before "--" are given to nix-build,
-    # and all arguments after "--" are given to the
-    # executed command. stdin is redirected to the executed
-    # command.
-
-    out=$(mktemp)
-    rm "$out"
-
-    # parse args into args1 and args2, separated by --
-    # args1 goes to nix-build, args2 goes to the built command
-    args1=("$@")
-    args2=()
-    for i in "''${!args1[@]}"; do
-      if [ "''${args1[$i]}" == "--" ]; then
-        args2=("''${args1[@]:$((i+1))}")
-        args1=("''${args1[@]:0:$((i))}")
-        break
-      fi
-    done
-
-    if nix-build -o "$out" "''${args1[@]}" >/dev/null; then
-      target=$(readlink -m "$out")
-      unlink "$out"
-      if test -f "$target" && test -x "$target"; then
-        exec "$target" "''${args2[@]}" <&0
-      else
-        echo "nix-run: No executable target produced by nix-build"
-        exit 1
-      fi
-    else
-      echo "nix-run: nix-build failed"
-      exit 1
-    fi
-  '';
-
-in stdenv.mkDerivation {
-  name = "nix-run";
-  phases = [ "installPhase" ];
-  installPhase = ''
-    mkdir -p $out/bin
-    ln -s ${nix-run} $out/bin/nix-run
-  '';
-  meta = {
-    description = ''
-      Wrapper around nix-build that automatically executes the binary
-      produced by the provided Nix expression.
-    '';
-    longDescription = ''
-      nix-run invokes nix-build with any options given to it. It then
-      expects one executable file to be produced by nix-build. If this
-      is the case, that file is executed with any options that is given
-      to nix-run after a <literal>--</literal> option separator. If no
-      executable file is produced by nix-build, nix-run will exit with
-      an error. An example invocation of nix-run is <literal>nix-run -A
-      myattr mynix.nix -- -o opt</literal>. nix-run will then build the
-      attribute <literal>myattr</literal> from the Nix expression given
-      in the file <literal>mynix.nix</literal>. If a single executable
-      file is produced, that file is executed with the option
-      <literal>-o opt</literal>.
-    '';
-    maintainers = [ stdenv.lib.maintainers.rickynils ];
-    platforms = stdenv.lib.platforms.linux;
-  };
-}