summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2014-05-27 02:31:27 -0700
committerMichael Raskin <7c6f434c@mail.ru>2014-05-27 02:31:27 -0700
commit80cc011f7763099fed75cd65647477ebec3294b4 (patch)
tree154ff437f364677b3a202d6903847571a568934c /pkgs/misc
parentaa9776028524986d1ef3272f1ec3f832277679cd (diff)
parent8ffd6af27e6dfae0a3b4d77db03409f62c5b8d98 (diff)
downloadnixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar.gz
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar.bz2
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar.lz
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar.xz
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.tar.zst
nixlib-80cc011f7763099fed75cd65647477ebec3294b4.zip
Merge pull request #2617 from ttuegel/hplip
hplip: update and fix scanning
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/drivers/hplip/default.nix86
-rw-r--r--pkgs/misc/drivers/hplip/hplip.state4
2 files changed, 74 insertions, 16 deletions
diff --git a/pkgs/misc/drivers/hplip/default.nix b/pkgs/misc/drivers/hplip/default.nix
index 5b9ef87a1297..fcec3bf26754 100644
--- a/pkgs/misc/drivers/hplip/default.nix
+++ b/pkgs/misc/drivers/hplip/default.nix
@@ -1,26 +1,34 @@
-{stdenv, fetchurl, cups, zlib, libjpeg, libusb, pythonPackages, saneBackends, dbus
-, pkgconfig, polkit, qtSupport ? true, qt4, pythonDBus, pyqt4, net_snmp
+{ stdenv, fetchurl, automake, pkgconfig
+, cups, zlib, libjpeg, libusb1, pythonPackages, saneBackends, dbus
+, polkit, qtSupport ? true, qt4, pythonDBus, pyqt4, net_snmp
+, withPlugin ? false
 }:
 
 stdenv.mkDerivation rec {
-  name = "hplip-3.11.1";
+  name = "hplip-3.14.4";
 
   src = fetchurl {
     url = "mirror://sourceforge/hplip/${name}.tar.gz";
-    sha256 = "0y68s4xm5d0kv7p5j41qq0xglp4vdbjwbrjs89b4a21wwn69hp9g";
+    sha256 = "1j8h44f8igl95wqypj4rk9awcw513hlps980jmcnkx60xghc4l6f";
   };
 
-  #preBuild=''
-  #  makeFlags="V=1 DISABLE_JBIG=1 CUPSFILTER=$out/lib/cups/filter CUPSPPD=$out/share/cups/model"
-  #'';
+  plugin = fetchurl {
+    url = "http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/${name}-plugin.run";
+    sha256 = "0k1vpmy7babbm3c5v4dcbhq0jgyr8as722nylfs8zx0dy7kr8874";
+  };
+
+  hplip_state = ./hplip.state;
 
   prePatch = ''
-    sed -i s,/etc/sane.d,$out/etc/sane.d/, Makefile.in
-    sed -i s,/etc/hp/,$out/etc/hp/, base/g.py
+    # HPLIP hardcodes absolute paths everywhere. Nuke from orbit.
+    find . -type f -exec sed -i s,/etc/hp,$out/etc/hp, {} \;
+    find . -type f -exec sed -i s,/etc/sane.d,$out/etc/sane.d, {} \;
+    find . -type f -exec sed -i s,/usr/include/libusb-1.0,${libusb1}/include/libusb-1.0, {} \;
+    find . -type f -exec sed -i s,/usr/share/hal/fdi/preprobe/10osvendor,$out/share/hal/fdi/preprobe/10osvendor, {} \;
+    find . -type f -exec sed -i s,/usr/lib/systemd/system,$out/lib/systemd/system, {} \;
+    find . -type f -exec sed -i s,/var/lib/hp,$out/var/lib/hp, {} \;
   '';
 
-  # --disable-network-build Until we have snmp
-
   preConfigure = ''
     export configureFlags="$configureFlags
       --with-cupsfilterdir=$out/lib/cups/filter
@@ -33,23 +41,66 @@ stdenv.mkDerivation rec {
 
     export makeFlags="
       halpredir=$out/share/hal/fdi/preprobe/10osvendor
-      hplip_statedir=$out/var
       rulesdir=$out/etc/udev/rules.d
       policykit_dir=$out/share/polkit-1/actions
       policykit_dbus_etcdir=$out/etc/dbus-1/system.d
       policykit_dbus_sharedir=$out/share/dbus-1/system-services
       hplip_confdir=$out/etc/hp
+      hplip_statedir=$out/var/lib/hp
     ";
   '';
 
-  postInstall = ''
+  postInstall =
+    ''
     wrapPythonPrograms
-    '';
+    ''
+    + (stdenv.lib.optionalString withPlugin
+    (let hplip_arch =
+          if builtins.currentSystem == "i686-linux"
+            then "x86_32"
+            else if builtins.currentSystem == "x86_64-linux"
+              then "x86_64"
+              else abort "Platform must be i686-linux or x86_64-linux!";
+    in
+    ''
+    sh ${plugin} --noexec --keep
+    cd plugin_tmp
+
+    cp plugin.spec $out/share/hplip/
+
+    mkdir -p $out/share/hplip/data/firmware
+    cp *.fw.gz $out/share/hplip/data/firmware
+
+    mkdir -p $out/share/hplip/data/plugins
+    cp license.txt $out/share/hplip/data/plugins
+
+    mkdir -p $out/share/hplip/prnt/plugins
+    for plugin in lj hbpl1; do
+      cp $plugin-${hplip_arch}.so $out/share/hplip/prnt/plugins
+      ln -s $out/share/hplip/prnt/plugins/$plugin-${hplip_arch}.so \
+        $out/share/hplip/prnt/plugins/$plugin.so
+    done
+
+    mkdir -p $out/share/hplip/scan/plugins
+    for plugin in bb_soap bb_marvell bb_soapht fax_marvell; do
+      cp $plugin-${hplip_arch}.so $out/share/hplip/scan/plugins
+      ln -s $out/share/hplip/scan/plugins/$plugin-${hplip_arch}.so \
+        $out/share/hplip/scan/plugins/$plugin.so
+    done
+
+    mkdir -p $out/var/lib/hp
+    cp ${hplip_state} $out/var/lib/hp/hplip.state
+
+    mkdir -p $out/etc/sane.d/dll.d
+    mv $out/etc/sane.d/dll.conf $out/etc/sane.d/dll.d/hpaio.conf
+
+    rm $out/etc/udev/rules.d/56-hpmud.rules
+    ''));
 
   buildInputs = [
       libjpeg
       cups
-      libusb
+      libusb1
       pythonPackages.python
       pythonPackages.wrapPython
       saneBackends
@@ -59,15 +110,18 @@ stdenv.mkDerivation rec {
     ] ++ stdenv.lib.optional qtSupport qt4;
 
   pythonPath = with pythonPackages; [
+      pillow
       pythonDBus
       pygobject
       recursivePthLoader
+      reportlab
     ] ++ stdenv.lib.optional qtSupport pyqt4;
 
   meta = with stdenv.lib; {
     description = "Print, scan and fax HP drivers for Linux";
     homepage = http://hplipopensource.com/;
-    license = "free"; # MIT/BSD/GPL
+    license = if withPlugin then licenses.unfree else "free"; # MIT/BSD/GPL
     platforms = platforms.linux;
+    maintainers = with maintainers; [ ttuegel ];
   };
 }
diff --git a/pkgs/misc/drivers/hplip/hplip.state b/pkgs/misc/drivers/hplip/hplip.state
new file mode 100644
index 000000000000..52679963f064
--- /dev/null
+++ b/pkgs/misc/drivers/hplip/hplip.state
@@ -0,0 +1,4 @@
+[plugin]
+installed=1
+eula=1
+version=3.14.4