summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2014-09-03 21:49:05 +0400
committerMichael Raskin <7c6f434c@mail.ru>2014-09-03 21:49:05 +0400
commit3f1ce8d864ac90737cd1129f0a4db156e529d7fb (patch)
tree55537024e90795b319feabcd3219167b7e919f3a /pkgs/misc
parent4c41c1ffbf347ef71460f316f7c26863603d8069 (diff)
parentf5f4bf1a25464e03441c852c791f7ee8780536a1 (diff)
downloadnixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar.gz
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar.bz2
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar.lz
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar.xz
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.tar.zst
nixlib-3f1ce8d864ac90737cd1129f0a4db156e529d7fb.zip
Merge pull request #3886 from AndersonTorres/higan
Higan - a quick&dirty workaround
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/higan/builder.sh15
-rw-r--r--pkgs/misc/emulators/higan/default.nix3
2 files changed, 17 insertions, 1 deletions
diff --git a/pkgs/misc/emulators/higan/builder.sh b/pkgs/misc/emulators/higan/builder.sh
index 144c23d39de5..0d01f7dc971f 100644
--- a/pkgs/misc/emulators/higan/builder.sh
+++ b/pkgs/misc/emulators/higan/builder.sh
@@ -18,3 +18,18 @@ install -m 644 ananke/libananke.so $out/lib/libananke.so.1
 (cd $out/lib && ln -s libananke.so.1 libananke.so)
 oldRPath=$(patchelf --print-rpath $out/bin/higan)
 patchelf --set-rpath $oldRPath:$out/lib $out/bin/higan
+
+# A dirty workaround, suggested by @cpages:
+# we create a first-run script to populate
+# the local $HOME with all the auxiliary
+# stuff needed by higan at runtime
+
+cat <<EOF > $out/bin/higan-config.sh
+#!${shell}
+
+cp --update --recursive $out/share/higan \$HOME/.config
+chmod --recursive u+w \$HOME/.config/higan
+
+EOF
+
+chmod +x $out/bin/higan-config.sh
diff --git a/pkgs/misc/emulators/higan/default.nix b/pkgs/misc/emulators/higan/default.nix
index aceb55b13967..532eeef2280f 100644
--- a/pkgs/misc/emulators/higan/default.nix
+++ b/pkgs/misc/emulators/higan/default.nix
@@ -44,5 +44,6 @@ stdenv.mkDerivation rec {
 # TODO:
 #   - options to choose profiles (accuracy, balanced, performance)
 #     and different GUIs (gtk2, qt4)
-#   - fix the BML and BIOS paths - maybe a custom patch to Higan project?
+#   - fix the BML and BIOS paths - maybe submitting
+#     a custom patch to Higan project would not be a bad idea...
 #