summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2017-12-20 03:40:33 +0000
committerGitHub <noreply@github.com>2017-12-20 03:40:33 +0000
commit3445138387e86b6223400416e6f9a0bbc1dd2800 (patch)
tree07c4d084d04cd7b3cd5760195e4bb51a7476b743 /pkgs/misc
parenta0aeb2381e5a6c5c57efdec1bf4b4ada44d29511 (diff)
parent438d4255a834cba347cf68f69a0a575c2e4c25f8 (diff)
downloadnixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar.gz
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar.bz2
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar.lz
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar.xz
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.tar.zst
nixlib-3445138387e86b6223400416e6f9a0bbc1dd2800.zip
Merge pull request #32833 from jtojnar/vala-cleanup
Vala cleanup
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/seafile-shared/default.nix41
1 files changed, 17 insertions, 24 deletions
diff --git a/pkgs/misc/seafile-shared/default.nix b/pkgs/misc/seafile-shared/default.nix
index d302fbe6d4b6..537576ca63b6 100644
--- a/pkgs/misc/seafile-shared/default.nix
+++ b/pkgs/misc/seafile-shared/default.nix
@@ -1,42 +1,35 @@
-{stdenv, fetchurl, which, automake, autoconf, pkgconfig, curl, libtool, vala_0_23, python, intltool, fuse, ccnet}:
+{stdenv, fetchurl, which, autoreconfHook, pkgconfig, curl, vala, python, intltool, fuse, ccnet}:
 
-stdenv.mkDerivation rec
-{
+stdenv.mkDerivation rec {
   version = "6.1.0";
   name = "seafile-shared-${version}";
 
-  src = fetchurl
-  {
+  src = fetchurl {
     url = "https://github.com/haiwen/seafile/archive/v${version}.tar.gz";
     sha256 = "03zvxk25311xgn383k54qvvpr8xbnl1vxd99fg4ca9yg5rmir1q6";
   };
 
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ which automake autoconf libtool vala_0_23 python intltool fuse ];
+  nativeBuildInputs = [ pkgconfig which autoreconfHook vala intltool ];
+  buildInputs = [ python fuse ];
   propagatedBuildInputs = [ ccnet curl ];
 
-  preConfigure = ''
-  sed -ie 's|/bin/bash|${stdenv.shell}|g' ./autogen.sh
-  ./autogen.sh
-  '';
-
-  configureFlags = "--disable-server --disable-console";
-
-  buildPhase = "make -j1";
+  configureFlags = [
+    "--disable-server"
+    "--disable-console"
+  ];
 
   postInstall = ''
-  # Remove seafile binary
-  rm -rf "$out/bin/seafile"
-  # Remove cli client binary
-  rm -rf "$out/bin/seaf-cli"
+    # Remove seafile binary
+    rm -rf "$out/bin/seafile"
+    # Remove cli client binary
+    rm -rf "$out/bin/seaf-cli"
   '';
 
-  meta =
-  {
+  meta = with stdenv.lib; {
     homepage = https://github.com/haiwen/seafile;
     description = "Shared components of Seafile: seafile-daemon, libseafile, libseafile python bindings, manuals, and icons";
-    license = stdenv.lib.licenses.gpl3;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = [ stdenv.lib.maintainers.calrama ];
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.calrama ];
   };
 }