summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorThéophane Hufschmitt <theophane.hufschmitt@polytechnique.org>2015-10-03 10:38:55 +0200
committerThéophane Hufschmitt <theophane.hufschmitt@polytechnique.org>2015-10-05 15:55:34 +0200
commit2496ecc32702d136de5d8187e4498deae32f4e1f (patch)
treedf9b0bffdc8ee1f65a06e8f083222fc1d40a1f83 /pkgs/misc
parente206ea5b0c1a67fa38b9f017586682e1dad80393 (diff)
downloadnixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar.gz
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar.bz2
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar.lz
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar.xz
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.tar.zst
nixlib-2496ecc32702d136de5d8187e4498deae32f4e1f.zip
vimPlugins.ctrlp: fixed upstream url
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/default.nix35
-rw-r--r--pkgs/misc/vim-plugins/vim-plugin-names2
2 files changed, 25 insertions, 12 deletions
diff --git a/pkgs/misc/vim-plugins/default.nix b/pkgs/misc/vim-plugins/default.nix
index b7468e539b9c..300289284b3f 100644
--- a/pkgs/misc/vim-plugins/default.nix
+++ b/pkgs/misc/vim-plugins/default.nix
@@ -47,6 +47,7 @@ rec {
   colorsamplerpack    = Colour_Sampler_Pack;
   command_T           = command-t; # backwards compat, added 2014-10-18
   css_color_5056      = vim-css-color;
+  ctrlp               = ctrlp-vim;
   easy-align          = vim-easy-align;
   easymotion          = vim-easymotion;
   eighties            = vim-eighties;
@@ -54,6 +55,7 @@ rec {
   gist-vim            = Gist;
   gitgutter           = vim-gitgutter;
   gundo               = gundo-vim;
+  Gundo               = gundo-vim; # backwards compat, added 2015-10-03
   haskellConceal      = haskellconceal; # backwards compat, added 2014-10-18
   haskellconceal      = vim-haskellconceal;
   hier                = vim-hier;
@@ -96,6 +98,17 @@ rec {
 
   };
 
+  CSApprox = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "CSApprox-2013-07-26";
+    src = fetchgit {
+      url = "git://github.com/godlygeek/csapprox";
+      rev = "7981dac51d8b6776985aa08cb7b5ee98ea7f2ddd";
+      sha256 = "8ccb47eb79c7ab63109d32158388812bdca340985527af4f2a5489ff8683389f";
+    };
+    dependencies = [];
+
+  };
+
   CheckAttach = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "CheckAttach-2015-06-22";
     src = fetchgit {
@@ -266,17 +279,6 @@ rec {
 
   };
 
-  ctrlp = buildVimPluginFrom2Nix { # created by nix#NixDerivation
-    name = "ctrlp-2013-07-29";
-    src = fetchgit {
-      url = "git://github.com/kien/ctrlp.vim";
-      rev = "b5d3fe66a58a13d2ff8b6391f4387608496a030f";
-      sha256 = "41f7884973770552395b96f8693da70999dc815462d4018c560d3ff6be462e76";
-    };
-    dependencies = [];
-
-  };
-
   ctrlp-py-matcher = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "ctrlp-py-matcher-2015-07-18";
     src = fetchgit {
@@ -376,6 +378,17 @@ rec {
 
   };
 
+  ctrlp-vim = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "ctrlp-vim-2015-09-15";
+    src = fetchgit {
+      url = "git://github.com/ctrlpvim/ctrlp.vim";
+      rev = "58247bdf8550879e183c13860eefa03983959e4a";
+      sha256 = "1d4cf293a1e48564a491e00077794e23f5360827a72c2618fd3e99ee153ea6a8";
+    };
+    dependencies = [];
+
+  };
+
   vim-jade = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "vim-jade-2015-07-06";
     src = fetchgit {
diff --git a/pkgs/misc/vim-plugins/vim-plugin-names b/pkgs/misc/vim-plugins/vim-plugin-names
index 9661419b7475..ba7f33b7dc83 100644
--- a/pkgs/misc/vim-plugins/vim-plugin-names
+++ b/pkgs/misc/vim-plugins/vim-plugin-names
@@ -16,7 +16,6 @@
 "WebAPI"
 "YankRing"
 "commentary"
-"ctrlp"
 "ctrlp-py-matcher"
 "ctrlp-z"
 "extradite"
@@ -27,6 +26,7 @@
 "github:mkasa/lushtags"
 "github:bitc/vim-hdevtools"
 "github:christoomey/vim-tmux-navigator"
+"github:ctrlpvim/ctrlp.vim"
 "github:eagletmt/neco-ghc"
 "github:esneider/YUNOcommit.vim"
 "github:fatih/vim-go"