summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorAndersonTorres <torres.anderson.85@gmail.com>2014-09-30 17:35:53 -0300
committerMateusz Kowalczyk <fuuzetsu@fuuzetsu.co.uk>2014-10-01 02:17:40 +0100
commit1c0d37a0382f06a0d24393006fb9aa45c53407e1 (patch)
treedfe3cc0c59eb1aef40556fb346da55430917dbba /pkgs/misc
parent0e9cf136af70220768af6f252d0e8151e312b714 (diff)
downloadnixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar.gz
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar.bz2
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar.lz
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar.xz
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.tar.zst
nixlib-1c0d37a0382f06a0d24393006fb9aa45c53407e1.zip
Higan: adding config.higan.{guiToolkit,profile} options
Now we can parametrize Higan locally.
By default, guiToolkit = "gtk" and profile = "performance" (the accuracy
profile is seriously slow on my machine :) )

Closes #4340
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/higan/default.nix21
1 files changed, 10 insertions, 11 deletions
diff --git a/pkgs/misc/emulators/higan/default.nix b/pkgs/misc/emulators/higan/default.nix
index 6ce3ca2356cd..b3c793f00e1c 100644
--- a/pkgs/misc/emulators/higan/default.nix
+++ b/pkgs/misc/emulators/higan/default.nix
@@ -4,12 +4,12 @@
 , udev
 , mesa, SDL
 , libao, openal, pulseaudio
-, profile ? "accuracy" # Options: accuracy, balanced, performance
-, gui ? "gtk" # can be gtk or qt4
+, profile ? "performance" # Options: accuracy, balanced, performance
+, guiToolkit ? "gtk" # can be gtk or qt4
 , gtk ? null, qt4 ? null }:
 
-assert gui == "gtk" || gui == "qt4";
-assert (gui == "gtk" -> gtk != null) || (gui == "qt4" -> qt4 != null);
+assert guiToolkit == "gtk" || guiToolkit == "qt4";
+assert (guiToolkit == "gtk" -> gtk != null) || (guiToolkit == "qt4" -> qt4 != null);
 
 stdenv.mkDerivation rec {
 
@@ -18,19 +18,19 @@ stdenv.mkDerivation rec {
   sourceName = "higan_v${version}-source";
 
   src = fetchurl {
-    url = "http://byuu.org/files/${sourceName}.tar.xz";
+    urls = [ "http://byuu.org/files/${sourceName}.tar.xz" "http://byuu.net/files/${sourceName}.tar.xz" ];
     sha256 = "06qm271pzf3qf2labfw2lx6k0xcd89jndmn0jzmnc40cspwrs52y";
     curlOpts = "--user-agent 'Mozilla/5.0'"; # the good old user-agent trick...
   };
 
   buildInputs = with stdenv.lib;
   [ pkgconfig libX11 libXv udev mesa SDL libao openal pulseaudio ]
-  ++ optionals (gui == "gtk") [ gtk ]
-  ++ optionals (gui == "qt4") [ qt4 ];
+  ++ optionals (guiToolkit == "gtk") [ gtk ]
+  ++ optionals (guiToolkit == "qt4") [ qt4 ];
 
   buildPhase = ''
-    make phoenix=${gui} profile=${profile} -C ananke
-    make phoenix=${gui} profile=${profile}
+    make phoenix=${guiToolkit} profile=${profile} -C ananke
+    make phoenix=${guiToolkit} profile=${profile}
   '';
 
   installPhase = ''
@@ -86,5 +86,4 @@ stdenv.mkDerivation rec {
 # TODO:
 #   - fix the BML and BIOS paths - maybe submitting
 #     a custom patch to Higan project would not be a bad idea...
-#   - config.higan.{gui,profile} options
-#
+#   - Qt support