summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-05-20 17:46:57 +0100
committerGitHub <noreply@github.com>2017-05-20 17:46:57 +0100
commit196fa7e70da4af8e2c3958a1a3ee206523da5a7a (patch)
treea9fcb5790ae2d85ec618e57f789ae6460261cb98 /pkgs/misc
parent0b21bd9dbde004dc984f107cc0676ba9b6185dff (diff)
parent1deb1a30c88113a46b794d8e99473d28e99c0b5a (diff)
downloadnixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar.gz
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar.bz2
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar.lz
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar.xz
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.tar.zst
nixlib-196fa7e70da4af8e2c3958a1a3ee206523da5a7a.zip
Merge pull request #25761 from Ma27/new-package/i3lock-pixeled
i3lock-pixeled: init at 1.1.0
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/screensavers/i3lock-pixeled/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/misc/screensavers/i3lock-pixeled/default.nix b/pkgs/misc/screensavers/i3lock-pixeled/default.nix
new file mode 100644
index 000000000000..b14812f920a8
--- /dev/null
+++ b/pkgs/misc/screensavers/i3lock-pixeled/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, pkgs, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "i3lock-pixeled-${version}";
+  version = "1.1.0";
+
+  src = fetchurl {
+    url = "https://github.com/Ma27/i3lock-pixeled/archive/${version}.tar.gz";
+    sha256 = "046qbx4qvcc66h53h4mm9pyjj9gjc6dzy38a0f0jc5a84xbivh7k";
+  };
+
+  propagatedBuildInputs = with pkgs; [
+    i3lock
+    imagemagick
+    scrot
+    playerctl
+  ];
+
+  buildPhases = [ "unpackPhase" "patchPhase" "installPhase" ];
+  makeFlags = [
+    "PREFIX=$(out)/bin"
+  ];
+
+  patchPhase = ''
+    substituteInPlace i3lock-pixeled \
+       --replace i3lock    "${pkgs.i3lock}/bin/i3lock" \
+       --replace convert   "${pkgs.imagemagick}/bin/convert" \
+       --replace scrot     "${pkgs.scrot}/bin/scrot" \
+       --replace playerctl "${pkgs.playerctl}/bin/playerctl#"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Simple i3lock helper which pixels a screenshot by scaling it down and up to get a pixeled version of the screen when the lock is active.";
+    homepage = "https://github.com/Ma27/i3lock-pixeled";
+    license = licenses.mit;
+    platform = platforms.linux;
+    maintainers = with maintainers; [ ma27 ];
+  };
+}