summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2017-07-24 09:25:16 +0800
committerPeter Hoeg <peter@hoeg.com>2017-07-24 09:37:58 +0800
commit0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca (patch)
tree82f686c1a309d0addf6965388eb7b22b51655be2 /pkgs/misc
parentdcd6467936bfcebd6db6885562ffba0ef5cef7ea (diff)
downloadnixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar.gz
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar.bz2
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar.lz
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar.xz
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.tar.zst
nixlib-0345aed90c3d76e10aa0db6de9dab48f3ed9d3ca.zip
mfcj6510dwlpr: use new xxd package instead of vim
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/drivers/mfcj6510dwlpr/default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/pkgs/misc/cups/drivers/mfcj6510dwlpr/default.nix b/pkgs/misc/cups/drivers/mfcj6510dwlpr/default.nix
index ee14e4a52db9..228f56d47ae0 100644
--- a/pkgs/misc/cups/drivers/mfcj6510dwlpr/default.nix
+++ b/pkgs/misc/cups/drivers/mfcj6510dwlpr/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgsi686Linux, dpkg, makeWrapper, coreutils, gnused, gawk, file, cups, patchelf, utillinux, vimNox
+{ stdenv, fetchurl, pkgsi686Linux, dpkg, makeWrapper, coreutils, gnused, gawk, file, cups, patchelf, utillinux, xxd
 , ghostscript, a2ps }:
 
 # Why:
@@ -61,7 +61,7 @@ stdenv.mkDerivation rec {
     ${utillinux}/bin/hexdump -ve '1/1 "%.2X"' $out/usr/bin/brprintconf_mfcj6510dw | \
     sed 's.2F6F70742F62726F746865722F5072696E746572732F25732F696E662F6272257366756E63.62726d66636a36353130647766756e63000000000000000000000000000000000000000000.' | \
     sed 's.2F6F70742F62726F746865722F5072696E746572732F25732F696E662F627225737263.62726D66636A3635313064777263000000000000000000000000000000000000000000.' | \
-    ${vimNox}/bin/xxd -r -p > $out/usr/bin/brprintconf_mfcj6510dw_patched
+    ${xxd}/bin/xxd -r -p > $out/usr/bin/brprintconf_mfcj6510dw_patched
     chmod +x $out/usr/bin/brprintconf_mfcj6510dw_patched
     #executing from current dir. segfaults if it's not r\w.
     mkdir -p $out/bin
@@ -79,11 +79,11 @@ stdenv.mkDerivation rec {
     '';
 
   meta = with stdenv.lib; {
-    homepage = http://www.brother.com/;
-    description = "Brother MFC-J6510DW LPR driver";
-    license = with licenses; unfree;
-    platforms = with platforms; linux;
+    description  = "Brother MFC-J6510DW LPR driver";
     downloadPage = http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcj6510dw_all&os=128;
-    maintainers = with maintainers; [ ramkromberg ];
+    homepage     = http://www.brother.com/;
+    license      = with licenses; unfree;
+    maintainers  = with maintainers; [ ramkromberg ];
+    platforms    = with platforms; linux;
   };
 }