summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2018-10-06 01:54:26 +0200
committerxeji <36407913+xeji@users.noreply.github.com>2018-10-06 01:54:26 +0200
commit02b0836d4273beda31cc005ca8f810bfd4881277 (patch)
treec9676b3aa50cbe84202fc2ef64487ff5feaef3a9 /pkgs/misc
parent938d98ebd5aec21faeb81919d9cda846f730d551 (diff)
downloadnixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar.gz
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar.bz2
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar.lz
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar.xz
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.tar.zst
nixlib-02b0836d4273beda31cc005ca8f810bfd4881277.zip
ghostscript: update hash (#47946)
I previously didn't update the hash, so was still building ghostscript-9.24
(which explained why docs were still from 9.24)

The ICC profile validation patch from #47937 is included in 9.25, so we
can strip it from the list of patches.

cc @xeji
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/ghostscript/default.nix7
-rw-r--r--pkgs/misc/ghostscript/icc-profile-validation.patch78
2 files changed, 2 insertions, 83 deletions
diff --git a/pkgs/misc/ghostscript/default.nix b/pkgs/misc/ghostscript/default.nix
index b554676f7756..20b91ba466a2 100644
--- a/pkgs/misc/ghostscript/default.nix
+++ b/pkgs/misc/ghostscript/default.nix
@@ -10,8 +10,7 @@ assert cupsSupport -> cups != null;
 let
   version = "9.${ver_min}";
   ver_min = "25";
-  # ghostscript*.tar.xz in https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs9xx/SHA512SUMS
-  sha512 = "dcbeeb5d3dd5ccaf949dc4be68363c50b1d35e647be4790a50b1bbf5f259f1d9181f705be27bfca708c4d270f945ff4b24e3db10b57800c1ee0ea7a40931c547";
+  sha512 = "18pcqzva7pq2a9mmqf9pq8x4winb6qmzni49vq2qx50k60rwyv1kdmixik3ym2bpj5p1j8g0vb47w7w2cf4lba5q583ylpd8rshn73s";
 
   fonts = stdenv.mkDerivation {
     name = "ghostscript-fonts";
@@ -44,7 +43,6 @@ stdenv.mkDerivation rec {
   };
 
   patches = [
-    ./icc-profile-validation.patch
     ./urw-font-files.patch
     ./doc-no-ref.diff
   ];
@@ -94,8 +92,7 @@ stdenv.mkDerivation rec {
     cp -r Resource "$out/share/ghostscript/${version}"
 
     mkdir -p "$doc/share/doc/ghostscript"
-    # docs are still built into 9.24
-    mv "$doc/share/doc/9.24" "$doc/share/doc/ghostscript/${version}"
+    mv "$doc/share/doc/${version}" "$doc/share/doc/ghostscript/"
 
     ln -s "${fonts}" "$out/share/ghostscript/fonts"
   '' + stdenv.lib.optionalString stdenv.isDarwin ''
diff --git a/pkgs/misc/ghostscript/icc-profile-validation.patch b/pkgs/misc/ghostscript/icc-profile-validation.patch
deleted file mode 100644
index c2b6f91cb30d..000000000000
--- a/pkgs/misc/ghostscript/icc-profile-validation.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From bc3df0773fccf4b4906a3e59652ad646ea0fee91 Mon Sep 17 00:00:00 2001
-From: Chris Liddell <chris.liddell@artifex.com>
-Date: Tue, 4 Sep 2018 17:01:08 +0100
-Subject: [PATCH] For ICC profile validation, have cups id iteself as DeviceN
-
-Give the range of color spaces and models that cups supports, we can't
-reasonably provide (or expect others to provide) output ICC profiles for all
-cases.
-
-For the purpose of profile validation, have it claim to be DeviceN and benefit
-from the extra tolerance in profiles allowed for that class of device.
----
- cups/gdevcups.c  | 15 ++++++++++++++-
- devices/devs.mak |  2 +-
- 2 files changed, 15 insertions(+), 2 deletions(-)
-
-diff --git a/cups/gdevcups.c b/cups/gdevcups.c
-index c1574f8..decd8eb 100644
---- a/cups/gdevcups.c
-+++ b/cups/gdevcups.c
-@@ -70,6 +70,7 @@
- #include "std.h"                /* to stop stdlib.h redefining types */
- #include "gdevprn.h"
- #include "gsparam.h"
-+#include "gxdevsop.h"
- #include "arch.h"
- #include "gsicc_manage.h"
-
-@@ -252,6 +253,7 @@ private int cups_put_params(gx_device *, gs_param_list *);
- private int cups_set_color_info(gx_device *);
- private dev_proc_sync_output(cups_sync_output);
- private prn_dev_proc_get_space_params(cups_get_space_params);
-+private int cups_spec_op(gx_device *dev_, int op, void *data, int datasize);
-
- #ifdef dev_t_proc_encode_color
- private cm_map_proc_gray(cups_map_gray);
-@@ -392,7 +394,7 @@ private gx_device_procs	cups_procs =
-    NULL,				/* push_transparency_state */
-    NULL,				/* pop_transparency_state */
-    NULL,                                /* put_image */
--
-+   cups_spec_op
- };
-
- #define prn_device_body_copies(dtype, procs, dname, w10, h10, xdpi, ydpi, lo, to, lm, bm, rm, tm, ncomp, depth, mg, mc, dg, dc, print_pages)\
-@@ -5927,6 +5929,17 @@ cups_print_planar(gx_device_printer *pdev,
-   return (0);
- }
-
-+private int
-+cups_spec_op(gx_device *dev_, int op, void *data, int datasize)
-+{
-+    /* Although not strictly DeviceN, the range of color models
-+       this device supports presets similar issues.
-+     */
-+    if (op == gxdso_supports_devn) {
-+        return true;
-+    }
-+    return gx_default_dev_spec_op(dev_, op, data, datasize);
-+}
-
- /*
-  */
-diff --git a/devices/devs.mak b/devices/devs.mak
-index c85604c..e8654e5 100644
---- a/devices/devs.mak
-+++ b/devices/devs.mak
-@@ -1860,7 +1860,7 @@ $(DD)pwgraster.dev : $(lcups_dev) $(lcupsi_dev) $(cups_) $(GDEV) \
- 	$(ADDMOD) $(DD)pwgraster -include $(lcups_dev)
- 	$(ADDMOD) $(DD)pwgraster -include $(lcupsi_dev)
-
--$(DEVOBJ)gdevcups.$(OBJ) : $(LCUPSSRCDIR)$(D)gdevcups.c $(std_h) $(DEVS_MAK) $(MAKEDIRS)
-+$(DEVOBJ)gdevcups.$(OBJ) : $(LCUPSSRCDIR)$(D)gdevcups.c $(std_h) $(gxdevsop_h) $(DEVS_MAK) $(MAKEDIRS)
- 	$(CUPS_CC) $(DEVO_)gdevcups.$(OBJ) $(C_) $(CFLAGS) $(CUPSCFLAGS) \
- 	    $(I_)$(GLSRC) \
- 	    $(I_)$(DEVSRC) \
---
-2.9.1