summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-02-25 19:57:34 +0000
committerShea Levy <shea@shealevy.com>2012-02-25 19:57:34 +0000
commitea195b2507b9068d966009d27c0e90b57d88f30d (patch)
tree287b4453ffa21139715bb1c1c57e6d01d1045295 /pkgs/lib
parent38e3d7bc86d2a48dd4d653fd3f142f422c075563 (diff)
parent385f242a400749b3923d51fff5a86403e6dab0dc (diff)
downloadnixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar.gz
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar.bz2
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar.lz
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar.xz
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.tar.zst
nixlib-ea195b2507b9068d966009d27c0e90b57d88f30d.zip
svn merge ^/nixpkgs/trunk
svn path=/nixpkgs/branches/stdenv-updates/; revision=32564
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/debug.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/debug.nix b/pkgs/lib/debug.nix
index d4d2702a2843..e452151add6b 100644
--- a/pkgs/lib/debug.nix
+++ b/pkgs/lib/debug.nix
@@ -42,7 +42,7 @@ rec {
       else if x == null then "x is null"
       else if isInt x then "x is an integer `${toString x}'"
       else if isString x then "x is a string `${substring 0 50 x}...'"
-      else "x is probably a path `${substring 0 50 (toString x)}'";
+      else "x is probably a path `${substring 0 50 (toString x)}...'";
 
   # trace the arguments passed to function and its result 
   # maybe rewrite these functions in a traceCallXml like style. Then one function is enough