summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2010-03-09 11:57:05 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2010-03-09 11:57:05 +0000
commita3111812ad6416d0c7a07ef661e91da17801dd8b (patch)
tree5dc6e9a0fd0575d0ddb7a30e76811deda1fd343a /pkgs/lib
parentb44af59afb163875b16771327b5c817afa5e2709 (diff)
downloadnixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar.gz
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar.bz2
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar.lz
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar.xz
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.tar.zst
nixlib-a3111812ad6416d0c7a07ef661e91da17801dd8b.zip
* In overrideDerivation, filter out the `type' attribute.
svn path=/nixpkgs/trunk/; revision=20487
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/customisation.nix b/pkgs/lib/customisation.nix
index 3b1bed3fc301..d5c9e99727e2 100644
--- a/pkgs/lib/customisation.nix
+++ b/pkgs/lib/customisation.nix
@@ -31,7 +31,7 @@ rec {
   overrideDerivation = drv: f:
     let
       # Filter out special attributes.
-      attrs = removeAttrs drv ["meta" "passthru" "outPath" "drvPath" "hostDrv" "buildDrv"];
+      attrs = removeAttrs drv ["meta" "passthru" "outPath" "drvPath" "hostDrv" "buildDrv" "type"];
       newDrv = derivation (attrs // (f drv));
     in newDrv //
       { meta = if drv ? meta then drv.meta else {};