summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2009-07-14 16:22:42 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2009-07-14 16:22:42 +0000
commit80cab44fce29e66356a1f7d30ef46c3be5f0c2b7 (patch)
tree296ba318c07cb719481f24d22ca5edf1f0ec9da2 /pkgs/lib
parent7f080535c466d958dad7218a72175030755f9e84 (diff)
downloadnixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar.gz
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar.bz2
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar.lz
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar.xz
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.tar.zst
nixlib-80cab44fce29e66356a1f7d30ef46c3be5f0c2b7.zip
* Options / config: these should be attrsets, not lists (IMHO).
svn path=/nixpkgs/trunk/; revision=16359
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/modules.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/lib/modules.nix b/pkgs/lib/modules.nix
index 0b92462ee3ee..2f1382ac93cb 100644
--- a/pkgs/lib/modules.nix
+++ b/pkgs/lib/modules.nix
@@ -62,8 +62,8 @@ rec {
   selectDeclsAndDefs = modules:
     lib.concatMap (m:
       if m ? config || m ? options then
-         attrByPath ["options"] [] m
-      ++ attrByPath ["config"] [] m
+         [ (attrByPath ["options"] {} m) ]
+      ++ [ (attrByPath ["config"] {} m) ]
       else
         [ m ]
     ) modules;