summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorNicolas Pierron <nicolas.b.pierron@gmail.com>2010-09-10 18:03:16 +0000
committerNicolas Pierron <nicolas.b.pierron@gmail.com>2010-09-10 18:03:16 +0000
commit7f8037cfd79c0fadf3ac5958b553ce0609fa3190 (patch)
treed4276a20a81a5d0528a9f0fa8399c12fac6048e3 /pkgs/lib
parent13f346058cf6fd1c37db29dadb1279c60fd97d0e (diff)
downloadnixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar.gz
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar.bz2
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar.lz
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar.xz
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.tar.zst
nixlib-7f8037cfd79c0fadf3ac5958b553ce0609fa3190.zip
Add additional shortcuts frequently used in NixOS.
svn path=/nixpkgs/trunk/; revision=23733
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/properties.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/lib/properties.nix b/pkgs/lib/properties.nix
index 4fa1b00a4116..46854d0e1431 100644
--- a/pkgs/lib/properties.nix
+++ b/pkgs/lib/properties.nix
@@ -309,7 +309,10 @@ rec {
 
   # Sugar to override the default value of the option by making a new
   # default value based on the configuration.
-  mkDefaultValue = content: mkOverride 1000 content;
+  mkDefaultValue = mkOverride 1000;
+  mkDefault = mkOverride 1000;
+  mkForce = mkOverride 50;
+  mkStrict = mkOverride 0;
 
   # Make the template traversal in function of the property traversal.  If
   # the template define a non-empty attribute set, then the property is