summary refs log tree commit diff
path: root/pkgs/lib/default.nix
diff options
context:
space:
mode:
authorNicolas Pierron <nicolas.b.pierron@gmail.com>2009-01-25 22:37:10 +0000
committerNicolas Pierron <nicolas.b.pierron@gmail.com>2009-01-25 22:37:10 +0000
commitc333a6ab6b25c1f7759ed54a0d86ebc393e62062 (patch)
treea842cf95c37dd42cda2b49299cc3b6fd6bf9b7ac /pkgs/lib/default.nix
parent74df154f731bc84bb42578789fe948ca953477b3 (diff)
downloadnixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar.gz
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar.bz2
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar.lz
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar.xz
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.tar.zst
nixlib-c333a6ab6b25c1f7759ed54a0d86ebc393e62062.zip
Add missing arguments to the "notHandle" functions of mergeOptionSets and filterOptionSets.
svn path=/nixpkgs/trunk/; revision=13872
Diffstat (limited to 'pkgs/lib/default.nix')
-rw-r--r--pkgs/lib/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index 0799683640a4..cea12bee0a1a 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -564,14 +564,14 @@ rec {
             else throw "Not defined."
           else opt.merge values
         );
-      notHandle = throw "Used without option declaration.";
+      notHandle = opts: throw "Used without option declaration.";
     };
 
   # Keep all option declarations.
   filterOptionSets =
     handleOptionSets {
       export = opt: values: opt;
-      notHandle = {};
+      notHandle = opts: {};
     };
 
   # Evaluate a list of option sets that would be merged with the