summary refs log tree commit diff
path: root/pkgs/lib/default.nix
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2008-12-02 12:26:28 +0000
committerMarc Weber <marco-oweber@gmx.de>2008-12-02 12:26:28 +0000
commit55976c6f8de0753c79c28dfa7e376bc3da9ee3db (patch)
treec9f24b6a7d4863d2d936e2212dfae4d0787c917b /pkgs/lib/default.nix
parentbd0b75fe28d8343e48851422834178cbe999647f (diff)
downloadnixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar.gz
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar.bz2
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar.lz
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar.xz
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.tar.zst
nixlib-55976c6f8de0753c79c28dfa7e376bc3da9ee3db.zip
depreceating functions which have been sud by me only replacements are in the following commits.. I still have to remove and adopt the code using them
svn path=/nixpkgs/trunk/; revision=13543
Diffstat (limited to 'pkgs/lib/default.nix')
-rw-r--r--pkgs/lib/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index 21b0c5f68357..1b54fd00ea88 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -614,6 +614,7 @@ rec {
       takeTillSlash (__sub (__stringLength s) 1) 1 s;
 
   # calls a function (f attr value ) for each record item. returns a list
+  # should be renamed to mapAttrsFlatten
   mapRecordFlatten = f : r : map (attr: f attr (builtins.getAttr attr r) ) (attrNames r);
 
   # maps a function on each attr value
@@ -661,6 +662,7 @@ rec {
   # { buildInputs = [a b]; }
   # merging buildPhase does'nt really make sense. The cases will be rare where appending /prefixing will fit your needs?
   # in these cases the first buildPhase will override the second one
+  # ! depreceated, use mergeAttrByFunc instead
   mergeAttrsNoOverride = { mergeLists ? ["buildInputs" "propagatedBuildInputs"],
                            overrideSnd ? [ "buildPhase" ]
                          } : attrs1 : attrs2 :
@@ -685,6 +687,7 @@ rec {
       subset_attr_names );
 
 # Marc 2nd proposal: (not everything has been tested in detail yet..)
+# depreceated because it's too complicated. use prepareDerivationArgs instead
 
   # usage / example
   # flagConfig = {