summary refs log tree commit diff
path: root/pkgs/lib/default.nix
diff options
context:
space:
mode:
authorNicolas Pierron <nicolas.b.pierron@gmail.com>2009-09-15 13:36:30 +0000
committerNicolas Pierron <nicolas.b.pierron@gmail.com>2009-09-15 13:36:30 +0000
commit0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a (patch)
tree133376465f776c01b4cc829977aa0398293ea000 /pkgs/lib/default.nix
parent07ed9e4611c1349aa038ab8da73d04fb8a650c2b (diff)
downloadnixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar.gz
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar.bz2
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar.lz
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar.xz
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.tar.zst
nixlib-0c16b00cbd9131fa646ec6b54dff2bd2d2c2ac1a.zip
Replace the traversal of modules:
- Remove handleOptionSets which used option declarations & definitions
in the same set.
- Add a traversal of modules where "config" and "options" are traverse at
the same time.

This allow to have accruate error messages with the incriminated files
playing a role in the error.

This system add a new restriction compare to the previous system:
- A module with no structure (option definitions & option declarations
& require) should not contain any option declarations.  If such module
exists you must convert it to the following form:

{ imports = <content of the require attribute>;
  options = <set of option declarations>;
  config = <set of option definitions>;
}

svn path=/nixpkgs/trunk/; revision=17163
Diffstat (limited to 'pkgs/lib/default.nix')
-rw-r--r--pkgs/lib/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index aec2fb0bcc06..2f916d3ddd73 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -23,4 +23,4 @@ in
   # !!! don't include everything at top-level; perhaps only the most
   # commonly used functions.
   // trivial // lists // strings // stringsWithDeps // attrsets // sources
-  // properties // options // types // meta // debug // misc
+  // properties // options // types // meta // debug // misc // modules