summary refs log tree commit diff
path: root/pkgs/lib/customisation.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-12-28 19:08:19 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-12-28 19:08:19 +0100
commit5be0a9acd7b9abe4bff3202a7ac7defc17a37877 (patch)
tree25491a83f604f1ace6a1170505955df5817495c2 /pkgs/lib/customisation.nix
parentf4ed8a3b911628335a53b3b5ddb48e9ec8d8bdcf (diff)
downloadnixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar.gz
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar.bz2
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar.lz
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar.xz
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.tar.zst
nixlib-5be0a9acd7b9abe4bff3202a7ac7defc17a37877.zip
Rename hostDrv -> crossDrv, buildDrv -> nativeDrv
This is for consistency with terminology in stdenv (and the terms
"hostDrv" and "buildDrv" are not very intuitive, even if they're
consistent with GNU terminology).
Diffstat (limited to 'pkgs/lib/customisation.nix')
-rw-r--r--pkgs/lib/customisation.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/lib/customisation.nix b/pkgs/lib/customisation.nix
index 54965ffb5804..18cec3209f97 100644
--- a/pkgs/lib/customisation.nix
+++ b/pkgs/lib/customisation.nix
@@ -34,7 +34,7 @@ rec {
   overrideDerivation = drv: f:
     let
       # Filter out special attributes.
-      drop = [ "meta" "passthru" "outPath" "drvPath" "hostDrv" "buildDrv" "type" "override" "deepOverride" "origArgs" "drvAttrs" "outputName" "all" "out" ]
+      drop = [ "meta" "passthru" "outPath" "drvPath" "crossDrv" "nativeDrv" "type" "override" "deepOverride" "origArgs" "drvAttrs" "outputName" "all" "out" ]
               # also drop functions such as .merge .override etc
              ++ lib.filter (n: isFunction (getAttr n drv)) (attrNames drv);
       attrs = removeAttrs drv drop;
@@ -44,10 +44,10 @@ rec {
         passthru = if drv ? passthru then drv.passthru else {};
       }
       //
-      (if (drv ? hostDrv && drv ? buildDrv)
+      (if (drv ? crossDrv && drv ? nativeDrv)
        then {
-         hostDrv = overrideDerivation drv.hostDrv f;
-         buildDrv = overrideDerivation drv.buildDrv f;
+         crossDrv = overrideDerivation drv.crossDrv f;
+         nativeDrv = overrideDerivation drv.nativeDrv f;
        }
        else { });