summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-06-25 11:53:02 +0200
committerGitHub <noreply@github.com>2018-06-25 11:53:02 +0200
commite0918b2550f78fc987451d451f03189e552cd237 (patch)
tree5da4ca6fd65d4573abc0bc0eb6f33437a136f7f7 /pkgs/games
parent1a54248903bf91007795fe10e4438150f839c406 (diff)
parentbe47f95083dcb46376041109235840bd584715dd (diff)
downloadnixlib-e0918b2550f78fc987451d451f03189e552cd237.tar
nixlib-e0918b2550f78fc987451d451f03189e552cd237.tar.gz
nixlib-e0918b2550f78fc987451d451f03189e552cd237.tar.bz2
nixlib-e0918b2550f78fc987451d451f03189e552cd237.tar.lz
nixlib-e0918b2550f78fc987451d451f03189e552cd237.tar.xz
nixlib-e0918b2550f78fc987451d451f03189e552cd237.tar.zst
nixlib-e0918b2550f78fc987451d451f03189e552cd237.zip
Merge pull request #42432 from Pneumaticat/multimc
multimc: fix build with Qt 5.11, fix desktop icon
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/multimc/default.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/pkgs/games/multimc/default.nix b/pkgs/games/multimc/default.nix
index c6697f5806d4..6be5c9ee2474 100644
--- a/pkgs/games/multimc/default.nix
+++ b/pkgs/games/multimc/default.nix
@@ -4,12 +4,14 @@ let
   libpath = with xorg; stdenv.lib.makeLibraryPath [ libX11 libXext libXcursor libXrandr libXxf86vm libpulseaudio ];
 in stdenv.mkDerivation rec {
   name = "multimc-${version}";
-  version = "0.6.2";
+  # Current release as of 2018-06-23 (v0.6.2) breaks under Qt 5.11—see
+  # https://github.com/NixOS/nixpkgs/issues/42387
+  version = "unstable-2018-06-04";
   src = fetchFromGitHub {
     owner = "MultiMC";
     repo = "MultiMC5";
-    rev = version;
-    sha256 = "07jrr6si8nzfqwf073zhgw47y6snib23ad3imh1ik1nn5r7wqy3c";
+    rev = "19bb50b872da2702b8e0b65f3f7b6b54c1c5b071";
+    sha256 = "01frkk2klm1axr7ywnj23ikxn5pkgj8q6w8vqbslsvmh8bni8rk0";
     fetchSubmodules = true;
   };
   nativeBuildInputs = [ cmake file makeWrapper ];
@@ -22,6 +24,12 @@ in stdenv.mkDerivation rec {
     cp ../application/resources/multimc/scalable/multimc.svg $out/share/pixmaps
     cp ../application/package/linux/multimc.desktop $out/share/applications
     wrapProgram $out/bin/MultiMC --add-flags "-d \$HOME/.multimc/" --set GAME_LIBRARY_PATH /run/opengl-driver/lib:${libpath} --prefix PATH : ${jdk}/bin/
+
+    # As of https://github.com/MultiMC/MultiMC5/blob/7ea1d68244fdae1e7672fb84199ee71e168b31ca/application/package/linux/multimc.desktop,
+    # the desktop icon refers to `multimc`, but the executable actually gets
+    # installed as `MultiMC`. Create compatibility symlink to fix the desktop
+    # icon.
+    ln -sf $out/bin/MultiMC $out/bin/multimc
   '';
 
   meta = with stdenv.lib; {