summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorYury G. Kudryashov <urkud.urkud@gmail.com>2012-02-20 05:30:06 +0000
committerYury G. Kudryashov <urkud.urkud@gmail.com>2012-02-20 05:30:06 +0000
commitd8454e538cb5c77bebdddacb4ad35cc7a27371f6 (patch)
tree899d7023cf918c7ce7244f392656a69104438165 /pkgs/games
parent1133387eb19eaeabee22a8ce229d21a59064ffd6 (diff)
parent23856c2a40c5ccf94903be91ca5709e518d58fc7 (diff)
downloadnixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar.gz
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar.bz2
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar.lz
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar.xz
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.tar.zst
nixlib-d8454e538cb5c77bebdddacb4ad35cc7a27371f6.zip
svn merge ^/nixpkgs/trunk
svn path=/nixpkgs/branches/stdenv-updates/; revision=32417
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/andyetitmoves/default.nix75
-rw-r--r--pkgs/games/super-tux-kart/default.nix12
-rw-r--r--pkgs/games/the-butterfly-effect/default.nix2
3 files changed, 84 insertions, 5 deletions
diff --git a/pkgs/games/andyetitmoves/default.nix b/pkgs/games/andyetitmoves/default.nix
new file mode 100644
index 000000000000..0b54e8286095
--- /dev/null
+++ b/pkgs/games/andyetitmoves/default.nix
@@ -0,0 +1,75 @@
+{ stdenv, fetchurl, libvorbis, libogg, libtheora, SDL, libXft, SDL_image, zlib, libX11, libpng, openal, requireFile, commercialVersion ? false }:
+
+let plainName = "andyetitmoves";
+    version   = "1.2.2";
+in
+
+stdenv.mkDerivation rec {
+  name = "${plainName}-${version}";
+
+  src = if stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux"
+    then
+      let postfix        = if stdenv.system == "i686-linux" then "i386" else "x86_64";
+          commercialName = "${plainName}-${version}_${postfix}.tar.gz";
+          demoUrl        = "http://www.andyetitmoves.net/demo/${plainName}Demo-${version}_${postfix}.tar.gz";
+      in
+      if commercialVersion
+        then requireFile {
+               message = ''
+                 We cannot download the commercial version automatically, as you require a license.
+                 Once you bought a license, you need to add your downloaded version to the nix store.
+                 You can do this by using "nix-prefetch-url file:///\$PWD/${commercialName}" in the
+                 directory where yousaved it.
+               '';
+               name = commercialName;
+               sha256 = if stdenv.system == "i686-linux"
+                          then "15wvzmmidvykwjrbnq70h5jrvnjx1hcrm0357qj85q4aqbzavh01"
+                          else "1v8z16qa9ka8sf7qq45knsxj87s6sipvv3a7xq11pb5xk08fb2ql";
+             }
+        else fetchurl {
+               url = demoUrl;
+               sha256 = if stdenv.system == "i686-linux"
+                          then "0f14vrrbq05hsbdajrb5y9za65fpng1lc8f0adb4aaz27x7sh525"
+                          else "0mg41ya0b27blq3b5498kwl4rj46dj21rcd7qd0rw1kyvr7sx4v4";
+             }
+    else
+      abort "And Yet It Moves nix package only supports linux and intel cpu's.";
+
+  phases = "unpackPhase installPhase";
+
+  installPhase = ''
+    ensureDir $out/{opt/andyetitmoves,bin}
+    cp -r * $out/opt/andyetitmoves/
+
+    fullPath=${stdenv.gcc.gcc}/lib64
+    for i in $buildNativeInputs; do
+      fullPath=$fullPath''${fullPath:+:}$i/lib
+    done
+
+    binName=${if commercialVersion then "AndYetItMoves" else "AndYetItMovesDemo"}
+
+    patchelf --set-interpreter $(cat $NIX_GCC/nix-support/dynamic-linker) --set-rpath $fullPath $out/opt/andyetitmoves/lib/$binName
+    cat > $out/bin/$binName << EOF
+    #!/bin/sh
+    cd $out/opt/andyetitmoves
+    exec ./lib/$binName
+    EOF
+    chmod +x $out/bin/$binName
+  '';
+
+  buildInputs = [libvorbis libogg libtheora SDL libXft SDL_image zlib libX11 libpng openal];
+
+  meta = {
+    description = "Physics/Gravity Platform game";
+
+    longDescription = ''
+      And Yet It Moves is an award-winning physics-based platform game in which players rotate the game world at will to solve challenging puzzles. Tilting the world turns walls into floors, slides into platforms, and stacks of rocks into dangerous hazards.
+    '';
+
+    homepage = http://www.andyetitmoves.net/;
+
+    license = "unfree";
+
+    maintainers = with stdenv.lib.maintainers; [bluescreen303];
+  };
+}
diff --git a/pkgs/games/super-tux-kart/default.nix b/pkgs/games/super-tux-kart/default.nix
index 722441121533..0c92ffbcdbb1 100644
--- a/pkgs/games/super-tux-kart/default.nix
+++ b/pkgs/games/super-tux-kart/default.nix
@@ -1,18 +1,22 @@
 { fetchurl, stdenv, plib, SDL, openal, freealut, mesa
-, libvorbis, libogg, gettext }:
+, libvorbis, libogg, gettext, irrlicht3843, libXxf86vm, curl, pkgconfig
+, fribidi }:
 
 stdenv.mkDerivation rec {
-  name = "supertuxkart-0.6.2a";
+  name = "supertuxkart-0.7.3";
 
   src = fetchurl {
     url = "mirror://sourceforge/supertuxkart/${name}-src.tar.bz2";
-    sha256 = "0bdn12kg85bgcgj9shfc40k56228hysiixfaxkycgb688nhldngr";
+    sha256 = "0njrs2qyhbiqdbsqk9jx0sl8nhdwmipf1i91k23rv1biwrim9yq7";
   };
 
   buildInputs = [
-    plib SDL openal freealut mesa libvorbis libogg gettext
+    plib SDL openal freealut mesa libvorbis libogg gettext irrlicht3843
+    libXxf86vm curl pkgconfig fribidi
   ];
 
+  configureFlags = [ "--with-irrlicht=${irrlicht3843}" ];
+
   postInstall = ''
     mv $out/games $out/bin
   '';
diff --git a/pkgs/games/the-butterfly-effect/default.nix b/pkgs/games/the-butterfly-effect/default.nix
index 99f73e07a631..5fc5e9be84e8 100644
--- a/pkgs/games/the-butterfly-effect/default.nix
+++ b/pkgs/games/the-butterfly-effect/default.nix
@@ -1,5 +1,5 @@
 x@{builderDefsPackage
-  , qt4, box2d
+  , qt4, box2d, which
   ,fetchsvn
   , ...}:
 builderDefsPackage