summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSergey Mironov <grrwlf@gmail.com>2013-08-18 00:19:54 +0400
committerBjørn Forsman <bjorn.forsman@gmail.com>2013-08-18 19:34:23 +0200
commitd5ddce7f768425158b259d64205114858ac0b572 (patch)
tree94997f0d91f586d46693b853b98fda208ca3f00b /pkgs/games
parent6ae213d3ae99ebe4a66c68db0dac2d1956fcb3a9 (diff)
downloadnixlib-d5ddce7f768425158b259d64205114858ac0b572.tar
nixlib-d5ddce7f768425158b259d64205114858ac0b572.tar.gz
nixlib-d5ddce7f768425158b259d64205114858ac0b572.tar.bz2
nixlib-d5ddce7f768425158b259d64205114858ac0b572.tar.lz
nixlib-d5ddce7f768425158b259d64205114858ac0b572.tar.xz
nixlib-d5ddce7f768425158b259d64205114858ac0b572.tar.zst
nixlib-d5ddce7f768425158b259d64205114858ac0b572.zip
instead: version 1.9.1, icon, .desktop, few more games
Instead is a textquest game engine. Games are located at

http://instead-games.sourceforge.net/
http://instead-games.ru/
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/instead/default.nix29
1 files changed, 14 insertions, 15 deletions
diff --git a/pkgs/games/instead/default.nix b/pkgs/games/instead/default.nix
index 0d46e187d7b6..6ab6b8d79d7b 100644
--- a/pkgs/games/instead/default.nix
+++ b/pkgs/games/instead/default.nix
@@ -1,19 +1,15 @@
 { stdenv, fetchurl, SDL, SDL_ttf, SDL_image, SDL_mixer, pkgconfig, lua, zlib, unzip }:
 
 let
-  version = "1.2.2";
+  version = "1.9.1";
 
-  # I took two games at random from http://instead.syscall.ru/games/
+  # I took several games at random from http://instead.syscall.ru/games/
   games = [
     (fetchurl {
       url = http://instead-games.googlecode.com/files/instead-apple-day-1.2.zip;
       sha256 = "0d4m554hiqmgl4xl0jp0b3bqjl35879768hqznh9y57y04sygd2a";
     })
     (fetchurl {
-      url = http://instead-games.googlecode.com/files/instead-cat-1.3.zip;
-      sha256 = "0vmsn7jg2vy5kqqbzad289vk4j3piarj1xpwyz72wgyc3k7djg4v";
-    })
-    (fetchurl {
       url = http://instead-games.googlecode.com/files/instead-cat_en-1.2.zip;
       sha256 = "0jlm3ssqlka16dm0rg6qfjh6xdh3pv7lj2s4ib4mqwj2vfy0v6sg";
     })
@@ -22,8 +18,12 @@ let
       sha256 = "15qdbg82zp3a8vz4qxminr0xbzbdpnsciliy2wm3raz4hnadawg1";
     })
     (fetchurl {
-      url = http://instead-games.googlecode.com/files/instead-toilet-1.1.zip;
-      sha256 = "17mlkr93y77pxhimq0v9f0w78fz8alkxwjwsr8z67p458iw6s1wr";
+      url = http://instead-games.googlecode.com/files/instead-toilet3in1-1.2.zip;
+      sha256 = "0wz4bljbg67m84qwpaqpzs934a5pcbhpgh39fvbbbfvnnlm4lirl";
+    })
+    (fetchurl {
+      url = http://instead-games.googlecode.com/files/instead-kayleth-0.4.1.zip;
+      sha256 = "0xmn9inys0kbcdd02qaqp8gazqs67xq3fq7hvcy2qb9jbq85j8b2";
     })
   ];
 in
@@ -32,8 +32,8 @@ stdenv.mkDerivation rec {
   name = "instead-" + version;
 
   src = fetchurl {
-    url = "http://instead.googlecode.com/files/instead_${version}.tar.gz";
-    sha256 = "178xxqvjl5v1bhjrlf8cqpkw85j25fldf0wn6bgyzicr6fspxb25";
+    url = "http://downloads.sourceforge.net/project/instead/instead/${version}/instead_${version}.tar.gz";
+    sha256 = "f5577c5118b5f4a2897c7bb26f3ad7993005dbf0ae8fe762b4434e1151ddb430";
   };
 
   NIX_LDFLAGS = "-llua -lgcc_s";
@@ -41,16 +41,15 @@ stdenv.mkDerivation rec {
   buildInputs = [ SDL SDL_ttf SDL_image SDL_mixer pkgconfig lua zlib unzip ];
 
   configurePhase = ''
-    sed -i -e "s,DATAPATH=.,DATAPATH=$out/share/${name}/," Rules.make
+    { echo 2; echo $out; } | ./configure.sh
   '';
 
   inherit games;
 
   installPhase = ''
-    mkdir -p $out/bin $out/share/${name}
-    cp sdl-instead $out/bin
-    cp -R games languages stead themes $out/share/${name}
-    pushd $out/share/${name}/games
+    make install
+
+    pushd $out/share/instead/games
     for a in $games; do
       unzip $a
     done